ar71xx: Remove ath10k packages from archer-c7-v1 (fixes FS#1743)
[openwrt/openwrt.git] / toolchain / Makefile
index 9432990f4f75e70895689796c5815953c7a0853d..0336b2f72cee18fefa66cce218c553b9b99a6e30 100644 (file)
@@ -70,6 +70,7 @@ endif
 endif
 
 ifdef CONFIG_BUILDBOT
+ifneq ($(wildcard $(TOPDIR)/.git),)
   $(TOOLCHAIN_DIR)/stamp/.ver_check: $(TMP_DIR)/.build
        cd "$(TOPDIR)"; git log --format=%h -1 toolchain > $(TMP_DIR)/.ver_check
        cmp -s $(TMP_DIR)/.ver_check $@ || { \
@@ -80,6 +81,7 @@ ifdef CONFIG_BUILDBOT
 
 $(TOOLCHAIN_DIR)/info.mk $(STAGING_DIR)/.prepared: $(TOOLCHAIN_DIR)/stamp/.ver_check
 endif
+endif
 
 # prerequisites for the individual targets
 $(curdir)/ := .config prereq