rename the Profile template that the image builder uses to prevent name conflicts...
[openwrt/openwrt.git] / toolchain / Makefile
index ceae2269a6c82f4c1ae6d06205d8a567cde10101..4682dbed17b696de08dbecba16e670c200c618dc 100644 (file)
@@ -25,7 +25,10 @@ install: $(TARGETS_INSTALL)
 clean: $(TARGETS_CLEAN)
 $(TARGETS_INSTALL): $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)
 
-uClibc-prepare: ccache-prepare kernel-headers-prepare
+ifeq ($(CONFIG_CCACHE),y)
+  uClibc-prepare: ccache-install
+endif
+uClibc-prepare: kernel-headers-prepare
 ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
   binutils-prepare: uClibc-prepare
   gcc-prepare: binutils-install