odhcp6c: Restart when server returns IAID error
[openwrt/openwrt.git] / toolchain / Makefile
index 2d8d88219da78ee764f8b76f9d30eee8eac4ef1e..581d2b3c60e160ae83f27845d37ec956b7e04a74 100644 (file)
@@ -1,72 +1,87 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # Main makefile for the toolchain
 #
-include $(TOPDIR)/rules.mk
-
-TARGETS-y:=kernel-headers libnotimpl
-TARGETS-$(CONFIG_GDB) += gdb
-ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
-  TARGETS-y+=binutils gcc uClibc
-endif
-
-TARGETS_DOWNLOAD:=$(patsubst %,%-download,$(TARGETS-y))
-TARGETS_INSTALL:=$(patsubst %,%-install,$(TARGETS-y))
-TARGETS_CLEAN:=$(patsubst %,%-clean,$(TARGETS-y))
+# Steps:
+# 1) toolchain/binutils/install
+#    build & install binutils
+# 2) toolchain/gcc/prepare
+#    build & install a minimal gcc, needed for steps 3 & 4
+# 3) toolchain/kernel-headers/install
+#    install kernel headers, needed for step 4
+# 4) toolchain/libc/prepare
+#    build & install libc headers & support files, needed for step 5
+# 5) toolchain/gcc/compile
+#    build & install an initial gcc, needed for step 6
+# 6) toolchain/libc/compile
+#    build & install the final libc
+# 7) toolchain/gcc/install
+#    build & install the final gcc
+# 8) toolchain/libc/install
+#    build & install libc utilities
+#
 
-all: install
-download: $(TARGETS_DOWNLOAD)
-install: $(TARGETS_INSTALL)
-clean: $(TARGETS_CLEAN)
-$(TARGETS_INSTALL): $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)
+curdir:=toolchain
 
-uClibc-prepare: kernel-headers-prepare
-ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
-  binutils-prepare: uClibc-prepare
-  gcc-prepare: binutils-install
-  uClibc-compile: gcc-compile
-  libnotimpl-compile: gcc-install
+# subdirectories to descend into
+$(curdir)/builddirs := $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_INSIGHT),insight) $(if $(CONFIG_EXTERNAL_TOOLCHAIN),wrapper,kernel-headers binutils gcc/minimal gcc/initial gcc/final $(LIBC)/headers $(LIBC))
+ifdef CONFIG_USE_UCLIBC
+  $(curdir)/builddirs += $(LIBC)/utils
 endif
-gcc-install: uClibc-install
-
-TOOLCHAIN_STAMP_DIR:=$(STAGING_DIR)/stampfiles
-
-$(STAGING_DIR)/$(REAL_GNU_TARGET_NAME):
-       @mkdir -p $@
-       @ln -sf ../lib $@/lib
+$(curdir)/builddirs-compile:=$($(curdir)/builddirs-prepare)
+$(curdir)/builddirs-install:=$($(curdir)/builddirs-compile)
 
-$(TOOLCHAIN_STAMP_DIR):
-       mkdir -p $@
+# builddir dependencies
+ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
+  $(curdir)/gcc/minimal/compile:=$(curdir)/binutils/install
+  $(curdir)/kernel-headers/install:=$(curdir)/gcc/minimal/install
+  $(curdir)/gcc/initial/prepare:=$(curdir)/gcc/minimal/prepare
+  $(curdir)/gcc/final/prepare:=$(curdir)/gcc/initial/prepare
 
-$(TOOLCHAIN_BUILD_DIR):
-       @mkdir -p $@
+  $(curdir)/$(LIBC)/headers/compile:=$(curdir)/kernel-headers/install
+  $(curdir)/gcc/initial/compile:=$(curdir)/$(LIBC)/headers/install
+  $(curdir)/$(LIBC)/compile:=$(curdir)/gcc/initial/install
+  $(curdir)/gcc/final/compile:=$(curdir)/$(LIBC)/install
+  $(curdir)/$(LIBC)/utils/compile:=$(curdir)/gcc/final/install
+  $(curdir)/$(LIBC)/prepare:=$(curdir)/$(LIBC)/headers/prepare
+  $(curdir)/$(LIBC)/utils/prepare:=$(curdir)/$(LIBC)/headers/prepare
+endif
 
-%-download: FORCE
-       $(MAKE) -C $(patsubst %-download,%,$@) download
+ifdef CONFIG_GCC_VERSION_LLVM
+  $(curdir)/builddirs += llvm
+  $(curdir)/gcc/minimal/compile += $(curdir)/llvm/install
+endif
 
-%-prepare: $(TOOLCHAIN_STAMP_DIR) $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME) $(TOOLCHAIN_BUILD_DIR) FORCE
-       @[ -f $(TOOLCHAIN_STAMP_DIR)/.toolchain_$@ ] || { \
-               $(MAKE) -C $(patsubst %-prepare,%,$@) prepare; \
-       }
-       @touch $(TOOLCHAIN_STAMP_DIR)/.toolchain_$@
+ifndef DUMP_TARGET_DB
+ifneq ($(ARCH),)
+  $(TOOLCHAIN_DIR)/info.mk: .config
+       @for dir in $(TOOLCHAIN_DIR); do ( \
+               $(if $(QUIET),,set -x;) \
+               mkdir -p "$$dir"; \
+               cd "$$dir"; \
+               ln -nsf lib lib64; \
+               ln -nsf lib lib32; \
+               mkdir -p stamp lib usr/include usr/lib ; \
+       ); done
+       @grep GCC_VERSION $@ >/dev/null 2>&1 || $(INSTALL_DATA) $(TOPDIR)/toolchain/info.mk $@
+       @touch $@
+endif
+endif
 
-%-compile: %-prepare 
-       @[ -f $(TOOLCHAIN_STAMP_DIR)/.toolchain_$@ ] || { \
-               $(MAKE) -C $(patsubst %-compile,%,$@) compile; \
-       }
-       @touch $(TOOLCHAIN_STAMP_DIR)/.toolchain_$@
+# prerequisites for the individual targets
+$(curdir)/ := .config prereq
+$(curdir)//prepare = $(STAGING_DIR)/.prepared $(TOOLCHAIN_DIR)/info.mk
+$(curdir)//compile = $(1)/prepare
+$(curdir)//install = $(1)/compile
 
-%-install: %-compile
-       @[ -f $(TOOLCHAIN_STAMP_DIR)/.toolchain_$@ ] || { \
-               $(MAKE) -C $(patsubst %-install,%,$@) install; \
-       }
-       @touch $(TOOLCHAIN_STAMP_DIR)/.toolchain_$@
+ifndef DUMP_TARGET_DB
+$(TOOLCHAIN_DIR)/stamp/.gcc-initial_installed:
+endif
 
-%-clean: FORCE
-       @$(MAKE) -C $(patsubst %-clean,%,$@) clean
-       @rm -f $(TOOLCHAIN_STAMP_DIR)/.toolchain_$(patsubst %-clean,%,$@)-*
+$(eval $(call stampfile,$(curdir),toolchain,install,$(TOOLCHAIN_DIR)/stamp/.gcc-initial_installed,,$(TOOLCHAIN_DIR)))
+$(eval $(call subdir,$(curdir)))