build: fix the toolchain rebuild check
[openwrt/openwrt.git] / toolchain / Makefile
index 48637c11bfbb5fbc14b519baf460877e1a7c4107..7a9730fd681f3a2f0e385e8966212c246696fae0 100644 (file)
@@ -1,63 +1,97 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # Main makefile for the toolchain
 #
-include $(TOPDIR)/rules.mk
+# Steps:
+# 1) toolchain/binutils/compile
+#    build & install binutils
+# 2) toolchain/gcc/minimal/compile
+#    build & install a minimal gcc, needed for steps 3 & 4
+# 3) toolchain/kernel-headers/compile
+#    install kernel headers, needed for step 4
+# 4) toolchain/libc/headers/compile
+#    build & install libc headers & support files, needed for step 5
+# 5) toolchain/gcc/initial/compile
+#    build & install an initial gcc, needed for step 6
+# 6) toolchain/libc/compile
+#    build & install the final libc
+# 7) toolchain/gcc/final/compile
+#    build & install the final gcc
+# 8) toolchain/libc/utils/compile
+#    build & install libc utilities
+#
+# For musl, steps 2 and 4 are skipped, and step 3 is done after 5
+
+curdir:=toolchain
 
-TARGETS-y:=kernel-headers
-TARGETS-$(CONFIG_GDB) += gdb
-ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
-  TARGETS-y+=binutils gcc uClibc
+# subdirectories to descend into
+$(curdir)/builddirs := $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_INSIGHT),insight) $(if $(CONFIG_EXTERNAL_TOOLCHAIN),wrapper,kernel-headers binutils gcc/initial gcc/final $(LIBC) fortify-headers) $(if $(CONFIG_YASM),yasm)
+ifdef CONFIG_USE_UCLIBC
+  $(curdir)/builddirs += $(LIBC)/utils
 endif
 
-TARGETS_DOWNLOAD:=$(patsubst %,%-download,$(TARGETS-y))
-TARGETS_PREPARE:=$(patsubst %,%-prepare,$(TARGETS-y))
-TARGETS_COMPILE:=$(patsubst %,%-compile,$(TARGETS-y))
-TARGETS_INSTALL:=$(patsubst %,%-install,$(TARGETS-y))
-TARGETS_CLEAN:=$(patsubst %,%-clean,$(TARGETS-y))
-STAMP:=$(STAGING_DIR)/stampfiles/.toolchain_installed
-
-all: install
-download: $(TARGETS_DOWNLOAD)
-compile: $(TARGETS_COMPILE)
-install: $(STAMP) 
-clean: $(TARGETS_CLEAN)
-
-ifneq ($(shell $(SCRIPT_DIR)/timestamp.pl -p . $(STAMP)),$(STAMP))
-  $(STAMP): $(TARGETS_INSTALL)
+# builddir dependencies
+ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
+  ifdef CONFIG_USE_MUSL
+    $(curdir)/kernel-headers/compile:=$(curdir)/gcc/initial/compile
+    $(curdir)/$(LIBC)/compile:=$(curdir)/kernel-headers/compile
+  else
+    $(curdir)/builddirs += $(LIBC)/headers gcc/minimal
+    $(curdir)/gcc/minimal/compile:=$(curdir)/binutils/compile
+    $(curdir)/kernel-headers/compile:=$(curdir)/gcc/minimal/compile
+    $(curdir)/$(LIBC)/headers/compile:=$(curdir)/kernel-headers/compile
+    $(curdir)/gcc/initial/compile:=$(curdir)/$(LIBC)/headers/compile
+  endif
+
+  $(curdir)/gcc/initial/compile+=$(curdir)/binutils/compile
+  $(curdir)/$(LIBC)/compile:=$(curdir)/gcc/initial/compile
+  $(curdir)/gcc/final/compile:=$(curdir)/$(LIBC)/compile
+  $(curdir)/$(LIBC)/utils/compile:=$(curdir)/gcc/final/compile
 endif
 
-uClibc-prepare: kernel-headers-prepare
-ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
-  binutils-prepare: uClibc-prepare
-  gcc-prepare: binutils-install
-  uClibc-compile: gcc-compile
+ifndef DUMP_TARGET_DB
+ifneq ($(ARCH),)
+  $(TOOLCHAIN_DIR)/info.mk: .config
+       @for dir in $(TOOLCHAIN_DIR); do ( \
+               $(if $(QUIET),,set -x;) \
+               mkdir -p "$$dir"; \
+               cd "$$dir"; \
+               ln -nsf lib lib64; \
+               ln -nsf lib lib32; \
+               mkdir -p stamp lib usr/include usr/lib ; \
+       ); done
+       @grep GCC_VERSION $@ >/dev/null 2>&1 || $(INSTALL_DATA) $(TOPDIR)/toolchain/info.mk $@
+       @touch $@
+endif
 endif
-gcc-install: uClibc-install
 
-$(STAMP):
-       mkdir -p $(shell dirname $@)
-       touch $@
+ifdef CONFIG_BUILDBOT
+  $(TOOLCHAIN_DIR)/stamp/.ver_check: $(TMP_DIR)/.build
+       cd "$(TOPDIR)"; git log --format=%h -1 toolchain > $(TMP_DIR)/.ver_check
+       cmp -s $(TMP_DIR)/.ver_check $@ || { \
+               rm -rf $(BUILD_DIR) $(STAGING_DIR) $(TOOLCHAIN_DIR) $(BUILD_DIR_TOOLCHAIN); \
+               mkdir -p $(TOOLCHAIN_DIR)/stamp; \
+               mv $(TMP_DIR)/.ver_check $@; \
+       }
 
-$(STAGING_DIR)/$(REAL_GNU_TARGET_NAME):
-       @mkdir -p $@
-       @ln -sf ../lib $@/lib
+$(TOOLCHAIN_DIR)/info.mk $(STAGING_DIR)/.prepared: $(TOOLCHAIN_DIR)/stamp/.ver_check
+endif
+
+# prerequisites for the individual targets
+$(curdir)/ := .config prereq
+$(curdir)//compile = $(STAGING_DIR)/.prepared $(TOOLCHAIN_DIR)/info.mk $(tools/stamp-compile)
 
-$(TOOLCHAIN_BUILD_DIR):
-       @mkdir -p $@
+ifndef DUMP_TARGET_DB
+$(TOOLCHAIN_DIR)/stamp/.gcc-initial_installed:
+endif
 
-%-prereq %-download %-clean %-refresh %-update: FORCE
-       $(MAKE) -C $* $(patsubst $*-%,%,$@)
+$(curdir)/install: $(curdir)/compile
 
-%-prepare: $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME) $(TOOLCHAIN_BUILD_DIR)       
-       $(MAKE) -C $* $(patsubst $*-%,%,$@)
+$(eval $(call stampfile,$(curdir),toolchain,compile,$(TOOLCHAIN_DIR)/stamp/.gcc-initial_installed,,$(TOOLCHAIN_DIR)))
+$(eval $(call stampfile,$(curdir),toolchain,check,$(TMP_DIR)/.build))
+$(eval $(call subdir,$(curdir)))
 
-%-compile: %-prepare FORCE
-       $(MAKE) -C $* $(patsubst $*-%,%,$@)
-       
-%-install: %-compile FORCE
-       $(MAKE) -C $* $(patsubst $*-%,%,$@)