use $(curdir) again
[openwrt/openwrt.git] / toolchain / Makefile
index 8636bce364706f67d92ee56712b34ae9c227106b..e0af602c2a3a4c0777017203c61c1ba5e2bc207e 100644 (file)
@@ -1,63 +1,32 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # Main makefile for the toolchain
 #
-include $(TOPDIR)/rules.mk
+file:=${lastword ${MAKEFILE_LIST}}
+curdir:=$(patsubst %/Makefile,%,${file})
 
-TARGETS-y:=kernel-headers
-TARGETS-$(CONFIG_GDB) += gdb
-ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
-  TARGETS-y+=binutils gcc uClibc
-endif
-
-TARGETS_DOWNLOAD:=$(patsubst %,%-download,$(TARGETS-y))
-TARGETS_PREPARE:=$(patsubst %,%-prepare,$(TARGETS-y))
-TARGETS_COMPILE:=$(patsubst %,%-compile,$(TARGETS-y))
-TARGETS_INSTALL:=$(patsubst %,%-install,$(TARGETS-y))
-TARGETS_CLEAN:=$(patsubst %,%-clean,$(TARGETS-y))
-STAMP:=$(STAGING_DIR)/stampfiles/.toolchain_installed
+# subdirectories to descend into
+$(curdir)/builddirs := kernel-headers $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_NATIVE_TOOLCHAIN),,binutils gcc uClibc)
 
-all: install
-download: $(TARGETS_DOWNLOAD)
-compile: $(TARGETS_COMPILE)
-install: $(STAMP) 
-clean: $(TARGETS_CLEAN)
-
-ifneq ($(shell $(SCRIPT_DIR)/timestamp.pl -p . $(STAMP)),$(STAMP))
-  $(STAMP): $(TARGETS_INSTALL)
-endif
-
-uClibc-prepare: kernel-headers-prepare
+# builddir dependencies
+$(curdir)/uClibc/prepare:=$(curdir)/kernel-headers/prepare
 ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
-  binutils-prepare: uClibc-prepare
-  gcc-prepare: binutils-install
-  uClibc-compile: gcc-compile
+  $(curdir)/binutils/prepare:=$(curdir)/uClibc/prepare
+  $(curdir)/gcc/prepare:=$(curdir)/binutils/install
+  $(curdir)/uClibc/compile:=$(curdir)/gcc/compile
 endif
-gcc-install: uClibc-install
-
-$(STAMP):
-       mkdir -p $(shell dirname $@)
-       touch $@
-
-$(STAGING_DIR)/$(REAL_GNU_TARGET_NAME):
-       @mkdir -p $@
-       @ln -sf ../lib $@/lib
-
-$(TOOLCHAIN_BUILD_DIR):
-       @mkdir -p $@
+$(curdir)/gcc/install:=$(curdir)/uClibc/install
 
-%-prereq %-download %-clean %-refresh: FORCE
-       $(MAKE) -C $* $(patsubst $*-%,%,$@)
+# prerequisites for the individual targets
+$(curdir)/ := .config $(tools/stamp)
+$(curdir)//prepare = $(STAGING_DIR)/include-host/.done
+$(curdir)//compile = $(1)/prepare
+$(curdir)//install = $(1)/compile
 
-%-prepare: $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME) $(TOOLCHAIN_BUILD_DIR)       
-       $(MAKE) -C $* $(patsubst $*-%,%,$@)
+$(eval $(call stampfile,$(curdir),toolchain))
+$(eval $(call subdir,$(curdir)))
 
-%-compile: %-prepare FORCE
-       $(MAKE) -C $* $(patsubst $*-%,%,$@)
-       
-%-install: %-compile FORCE
-       $(MAKE) -C $* $(patsubst $*-%,%,$@)