toolchain/gdb: use expat library to be able to parse target machine definitions
[openwrt/openwrt.git] / toolchain / binutils / Config.in
index 1868a06..8d91223 100644 (file)
@@ -2,27 +2,18 @@
 
 choice
        prompt "Binutils Version" if TOOLCHAINOPTS
-       default BINUTILS_VERSION_2_18 if TARGET_avr32
-       default BINUTILS_VERSION_2_18 if TARGET_ppc44x || TARGET_ppc40x
-       default BINUTILS_VERSION_2_17
+       default BINUTILS_VERSION_LINARO
        help
          Select the version of binutils you wish to use.
 
-       config BINUTILS_VERSION_2_17
-               bool "binutils 2.17"
-
-       config BINUTILS_VERSION_2_18
-               bool "binutils 2.18"
-
-       config BINUTILS_VERSION_2_19
-               depends !TARGET_avr32
-               bool "binutils 2.19"
+       config BINUTILS_VERSION_LINARO
+               bool "Linaro binutils 2.24"
 
 endchoice
 
 config EXTRA_BINUTILS_CONFIG_OPTIONS
        string
-       prompt "Additional binutils options" if TOOLCHAINOPTS
+       prompt "Additional binutils configure options" if TOOLCHAINOPTS
        default ""
        help
            Any additional binutils options you may want to include....
@@ -30,9 +21,5 @@ config EXTRA_BINUTILS_CONFIG_OPTIONS
 config BINUTILS_VERSION
        string
        prompt "Binutils Version" if (TOOLCHAINOPTS && NULL)
-       default "2.17"            if BINUTILS_VERSION_2_17
-       default "2.18"            if BINUTILS_VERSION_2_18
-       default "2.19"            if BINUTILS_VERSION_2_19
-       default "2.18"            if TARGET_avr32
-       default "2.18"            if TARGET_ppc44x || TARGET_ppc40x
-       default "2.17"
+       default "linaro"          if BINUTILS_VERSION_LINARO
+       default "linaro"