toolchain/gdb: use expat library to be able to parse target machine definitions
[openwrt/openwrt.git] / toolchain / binutils / Config.in
index 9b4fe07..8d91223 100644 (file)
@@ -2,23 +2,24 @@
 
 choice
        prompt "Binutils Version" if TOOLCHAINOPTS
-       default BINUTILS_VERSION_2_16_1
+       default BINUTILS_VERSION_LINARO
        help
          Select the version of binutils you wish to use.
 
-       config BINUTILS_VERSION_2_16_1
-               bool "binutils 2.16.1"
-
-       config BINUTILS_VERSION_2_17
-               bool "binutils 2.17"
+       config BINUTILS_VERSION_LINARO
+               bool "Linaro binutils 2.24"
 
 endchoice
 
+config EXTRA_BINUTILS_CONFIG_OPTIONS
+       string
+       prompt "Additional binutils configure options" if TOOLCHAINOPTS
+       default ""
+       help
+           Any additional binutils options you may want to include....
+
 config BINUTILS_VERSION
        string
        prompt "Binutils Version" if (TOOLCHAINOPTS && NULL)
-       default "2.16.1"          if BINUTILS_VERSION_2_16_1
-       default "2.17"            if BINUTILS_VERSION_2_17
-       default "2.16.1"
-
-
+       default "linaro"          if BINUTILS_VERSION_LINARO
+       default "linaro"