manual/Makefile: Don't mix pattern rules with normal rules.
[openwrt/openwrt.git] / toolchain / eglibc / Config.in
index 2ae8da3e85c46edfe41b0ae5789a5163aa08743c..2054e95b5dbc0cea6e0fbd715446401d6d58532a 100644 (file)
@@ -1,7 +1,7 @@
 choice
        prompt "eglibc version" 
        depends on TOOLCHAINOPTS && USE_EGLIBC
-       default EGLIBC_VERSION_2_8
+       default EGLIBC_VERSION_2_12
        help
          Select the version of eglibc you wish to use.
 
@@ -22,11 +22,15 @@ choice
 
        config EGLIBC_VERSION_2_11
                bool "eglibc 2.11"
-               depends GCC_VERSION_4_3 || GCC_VERSION_4_4 || GCC_VERSION_4_5
+               depends !GCC_VERSION_LLVM
 
        config EGLIBC_VERSION_2_12
                bool "eglibc 2.12"
-               depends GCC_VERSION_4_3 || GCC_VERSION_4_4 || GCC_VERSION_4_5
+               depends !GCC_VERSION_LLVM
+
+       config EGLIBC_VERSION_2_13
+               bool "eglibc 2.13"
+               depends !GCC_VERSION_LLVM
 
        config EGLIBC_VERSION_TRUNK
                bool "eglibc trunk"
@@ -44,6 +48,7 @@ config EGLIBC_REVISION
        default "10152" if EGLIBC_VERSION_2_10
        default "10454" if EGLIBC_VERSION_2_11
        default "10495" if EGLIBC_VERSION_2_12
+       default "13055" if EGLIBC_VERSION_2_13
        default "HEAD"  if EGLIBC_VERSION_TRUNK
        default ""