manual/Makefile: Don't mix pattern rules with normal rules.
[openwrt/openwrt.git] / toolchain / eglibc / Config.in
index 8f38d0981a5fb8ca4fafba393f09885f61dfd27d..2054e95b5dbc0cea6e0fbd715446401d6d58532a 100644 (file)
@@ -1,7 +1,7 @@
 choice
        prompt "eglibc version" 
        depends on TOOLCHAINOPTS && USE_EGLIBC
-       default EGLIBC_VERSION_2_8
+       default EGLIBC_VERSION_2_12
        help
          Select the version of eglibc you wish to use.
 
@@ -20,6 +20,18 @@ choice
        config EGLIBC_VERSION_2_10
                bool "eglibc 2.10"
 
+       config EGLIBC_VERSION_2_11
+               bool "eglibc 2.11"
+               depends !GCC_VERSION_LLVM
+
+       config EGLIBC_VERSION_2_12
+               bool "eglibc 2.12"
+               depends !GCC_VERSION_LLVM
+
+       config EGLIBC_VERSION_2_13
+               bool "eglibc 2.13"
+               depends !GCC_VERSION_LLVM
+
        config EGLIBC_VERSION_TRUNK
                bool "eglibc trunk"
 
@@ -32,8 +44,11 @@ config EGLIBC_REVISION
        default "5887"  if EGLIBC_VERSION_2_6
        default "8588"  if EGLIBC_VERSION_2_7
        default "8587"  if EGLIBC_VERSION_2_8
-       default "8690"  if EGLIBC_VERSION_2_9
-       default "9289"  if EGLIBC_VERSION_2_10
+       default "10153" if EGLIBC_VERSION_2_9
+       default "10152" if EGLIBC_VERSION_2_10
+       default "10454" if EGLIBC_VERSION_2_11
+       default "10495" if EGLIBC_VERSION_2_12
+       default "13055" if EGLIBC_VERSION_2_13
        default "HEAD"  if EGLIBC_VERSION_TRUNK
        default ""
 
@@ -41,4 +56,3 @@ menu "eglibc configuration"
        depends on TOOLCHAINOPTS && USE_EGLIBC
        source toolchain/eglibc/config/Config.in
 endmenu
-