add preliminary coldfire v4e support
[openwrt/openwrt.git] / toolchain / gcc / Config.version
index f38739e..1da3bdb 100644 (file)
@@ -3,8 +3,8 @@ config GCC_VERSION
        default "3.4.6"     if GCC_VERSION_3_4_6
        default "4.1.2"     if GCC_VERSION_4_1_2
        default "4.2.4"     if GCC_VERSION_4_2_4
-       default "4.3.2"     if GCC_VERSION_4_3_2
        default "4.3.3"     if GCC_VERSION_4_3_3
+       default "4.4.0"     if GCC_VERSION_4_4_0
        default "4.1.2"
 
 config GCC_VERSION_3
@@ -20,6 +20,7 @@ config GCC_VERSION_4
        default y       if GCC_VERSION_4_1
        default y       if GCC_VERSION_4_2
        default y       if GCC_VERSION_4_3
+       default y       if GCC_VERSION_4_4
 
 config GCC_VERSION_4_1
        bool
@@ -31,9 +32,12 @@ config GCC_VERSION_4_2
 
 config GCC_VERSION_4_3
        bool
-       default y       if GCC_VERSION_4_3_2
        default y       if GCC_VERSION_4_3_3
 
+config GCC_VERSION_4_4
+       bool
+       default y       if GCC_VERSION_4_4_0
+
 if !TOOLCHAINOPTS
        config GCC_VERSION_3_4_6
                default y if LINUX_2_4
@@ -43,6 +47,8 @@ if !TOOLCHAINOPTS
                default y if TARGET_ppc40x
                default y if TARGET_ppc44x
 
-       config GCC_VERSION_4_3_2
-               default y if TARGET_ps3
+       config GCC_VERSION_4_3_3
+               default y if TARGET_ps3_petitboot
+               default y if TARGET_etrax
+               default y if TARGET_coldfire
 endif