toolchain/gcc: Remove workaround for GCC 4.8
[openwrt/openwrt.git] / toolchain / gcc / common.mk
index b75fce57ef1c3d53d40cc43ae0e3569298c30073..2a6d75d0ddff7570710f46a95dae8fed53752653 100644 (file)
@@ -123,15 +123,12 @@ GCC_CONFIGURE:= \
                --with-gmp=$(TOPDIR)/staging_dir/host \
                --with-mpfr=$(TOPDIR)/staging_dir/host \
                --with-mpc=$(TOPDIR)/staging_dir/host \
-               --disable-decimal-float
+               --disable-decimal-float \
+               --with-diagnostics-color=auto-if-env
 ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
   GCC_CONFIGURE += --with-mips-plt
 endif
 
-ifndef GCC_VERSION_4_8
-  GCC_CONFIGURE += --with-diagnostics-color=auto-if-env
-endif
-
 ifneq ($(CONFIG_GCC_DEFAULT_PIE),)
   GCC_CONFIGURE+= \
                --enable-default-pie