We use different toolchain directories for different ARM archs, so we should set...
[openwrt/openwrt.git] / toolchain / gcc / common.mk
index 43ffb475532cc01bc9725aca4b9536d5b262c561..888cf7a1e5a8e846cc3dd95c2e421d42cb4d6637 100644 (file)
@@ -36,12 +36,12 @@ ifdef CONFIG_GCC_VERSION_LLVM
   PKG_SOURCE_SUBDIR:=$(GCC_DIR)
   HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(GCC_DIR)
 else
-ifeq ($(CONFIG_GCC_VERSION),"4.5.1+l")
-    PKG_REV:=4.5-2010.12-0
+ifeq ($(CONFIG_GCC_VERSION),"linaro")
+    PKG_REV:=4.5-2011.02-0
     PKG_VERSION:=4.5.2
-    PKG_SOURCE_URL:=http://launchpad.net/gcc-linaro/4.5/4.5-2010.12-0/+download/
+    PKG_SOURCE_URL:=http://launchpad.net/gcc-linaro/4.5/4.5-2011.02-0/+download/
     PKG_SOURCE:=$(PKG_NAME)-linaro-$(PKG_REV).tar.bz2
-    PKG_MD5SUM:=a01e511fd1a3b42b54d239b393f740fe
+    PKG_MD5SUM:=d93199c1296e053f57fcc7888b54d488
     GCC_DIR:=gcc-linaro-$(PKG_REV)
     HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(GCC_DIR)
 else
@@ -167,6 +167,10 @@ ifdef CONFIG_powerpc
   TARGET_CFLAGS := $(patsubst -Os,-O2,$(TARGET_CFLAGS))
 endif
 
+ifneq ($(GCC_ARCH),)
+  GCC_CONFIGURE+= --with-arch=$(GCC_ARCH)
+endif
+
 GCC_MAKE:= \
        export SHELL="$(BASH)"; \
        $(MAKE) $(TOOLCHAIN_JOBS) \