gcc: build with HOST_CFLAGS
[openwrt/openwrt.git] / toolchain / gcc / common.mk
index 6a092e0084ecfef1c932b3d2b2be23da96b41f7f..924ed90a63eb4b7cdc4e4cdd651d35a667038a92 100644 (file)
@@ -2,7 +2,7 @@
 # Copyright (C) 2002-2003 Erik Andersen <andersen@uclibc.org>
 # Copyright (C) 2004 Manuel Novoa III <mjn3@uclibc.org>
 # Copyright (C) 2005-2006 Felix Fietkau <nbd@openwrt.org>
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -35,52 +35,58 @@ ifdef CONFIG_GCC_VERSION_LLVM
   PKG_SOURCE_URL:=git://repo.or.cz/llvm-gcc-4.2.git
   PKG_SOURCE_SUBDIR:=$(GCC_DIR)
   HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(GCC_DIR)
+else
+ifeq ($(findstring linaro, $(CONFIG_GCC_VERSION)),linaro)
+    ifeq ($(CONFIG_GCC_VERSION),"4.5-linaro")
+      PKG_REV:=4.5-2012.03
+      PKG_VERSION:=4.5.4
+      PKG_VERSION_MAJOR:=4.5
+      PKG_MD5SUM:=0c25f93e15e362e352c933e4649a7fc6
+    endif
+    ifeq ($(CONFIG_GCC_VERSION),"4.6-linaro")
+      PKG_REV:=4.6-2012.11
+      PKG_VERSION:=4.6.4
+      PKG_VERSION_MAJOR:=4.6
+      PKG_MD5SUM:=d2632b8d3c0e44025dd1c8661db0c201
+    endif
+    ifeq ($(CONFIG_GCC_VERSION),"4.7-linaro")
+      PKG_REV:=4.7-2012.11
+      PKG_VERSION:=4.7.3
+      PKG_VERSION_MAJOR:=4.7
+      PKG_MD5SUM:=590481ff4aff1a9e0f9a206516248877
+    endif
+    PKG_SOURCE_URL:=http://launchpad.net/gcc-linaro/$(PKG_VERSION_MAJOR)/$(PKG_REV)/+download/
+    PKG_SOURCE:=$(PKG_NAME)-linaro-$(PKG_REV).tar.bz2
+    GCC_DIR:=gcc-linaro-$(PKG_REV)
+    HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(GCC_DIR)
 else
   PKG_SOURCE_URL:=@GNU/gcc/gcc-$(PKG_VERSION)
   PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 
-  ifeq ($(PKG_VERSION),3.4.6)
-    PKG_MD5SUM:=4a21ac777d4b5617283ce488b808da7b
-  endif
-  ifeq ($(PKG_VERSION),4.1.2)
-    PKG_MD5SUM:=a4a3eb15c96030906d8494959eeda23c
-  endif
-  ifeq ($(PKG_VERSION),4.2.4)
-    PKG_MD5SUM:=d79f553e7916ea21c556329eacfeaa16
-  endif
-  ifeq ($(PKG_VERSION),4.3.3)
-    PKG_MD5SUM:=cc3c5565fdb9ab87a05ddb106ba0bd1f
-  endif
-  ifeq ($(PKG_VERSION),4.3.4)
-    PKG_MD5SUM:=60df63222dbffd53ca11492a2545044f
-  endif
-  ifeq ($(PKG_VERSION),4.3.5)
-    PKG_MD5SUM:=e588cfde3bf323f82918589b94f14a15
-  endif
-  ifeq ($(PKG_VERSION),4,4,1)
-    PKG_MD5SUM:=927eaac3d44b22f31f9c83df82f26436
-  endif
-  ifeq ($(PKG_VERSION),4.4.2)
-    PKG_MD5SUM:=70f5ac588a79e3c9901d5b34f58d896d
+  ifeq ($(PKG_VERSION),4.4.7)
+    PKG_MD5SUM:=295709feb4441b04e87dea3f1bab4281
   endif
-  ifeq ($(PKG_VERSION),4.4.3)
-    PKG_MD5SUM:=fe1ca818fc6d2caeffc9051fe67ff103
+  ifeq ($(PKG_VERSION),4.6.2)
+    PKG_MD5SUM:=028115c4fbfb6cfd75d6369f4a90d87e
   endif
-  ifeq ($(PKG_VERSION),4.4.4)
-    PKG_MD5SUM:=7ff5ce9e5f0b088ab48720bbd7203530
+  ifeq ($(PKG_VERSION),4.6.3)
+    PKG_MD5SUM:=773092fe5194353b02bb0110052a972e
   endif
-  ifeq ($(PKG_VERSION),4.5.0)
-  PKG_MD5SUM:=ff27b7c4a5d5060c8a8543a44abca31f
+  ifeq ($(PKG_VERSION),4.7.0)
+    PKG_MD5SUM:=2a0f1d99fda235c29d40b561f81d9a77
   endif
-  ifeq ($(PKG_VERSION),4.5.1)
-  PKG_MD5SUM:=48231a8e33ed6e058a341c53b819de1a
+  ifeq ($(PKG_VERSION),4.7.2)
+    PKG_MD5SUM:=cc308a0891e778cfda7a151ab8a6e762
   endif
 endif
+endif
 
 PATCH_DIR=../patches/$(GCC_VERSION)
 
 BUGURL=https://dev.openwrt.org/
 
+HOST_BUILD_PARALLEL:=1
+
 include $(INCLUDE_DIR)/toolchain-build.mk
 
 HOST_SOURCE_DIR:=$(HOST_BUILD_DIR)
@@ -97,14 +103,17 @@ HOST_STAMP_CONFIGURED:=$(GCC_BUILD_DIR)/.configured
 HOST_STAMP_INSTALLED:=$(STAGING_DIR_HOST)/stamp/.gcc_$(GCC_VARIANT)_installed
 
 SEP:=,
-TARGET_LANGUAGES:="c$(if $(CONFIG_INSTALL_LIBSTDCPP),$(SEP)c++)$(if $(CONFIG_INSTALL_LIBGCJ),$(SEP)java)"
+TARGET_LANGUAGES:="c$(if $(CONFIG_INSTALL_LIBSTDCPP),$(SEP)c++)$(if $(CONFIG_INSTALL_LIBGCJ),$(SEP)java)$(if $(CONFIG_INSTALL_GFORTRAN),$(SEP)fortran)"
 
 export libgcc_cv_fixed_point=no
+ifdef CONFIG_USE_UCLIBC
+  export glibcxx_cv_c99_math_tr1=no
+endif
 
 GCC_CONFIGURE:= \
        SHELL="$(BASH)" \
        $(HOST_SOURCE_DIR)/configure \
-               --prefix=$(TOOLCHAIN_DIR)/usr \
+               --prefix=$(TOOLCHAIN_DIR) \
                --build=$(GNU_HOST_NAME) \
                --host=$(GNU_HOST_NAME) \
                --target=$(REAL_GNU_TARGET_NAME) \
@@ -115,28 +124,27 @@ GCC_CONFIGURE:= \
                --disable-multilib \
                --disable-nls \
                $(GRAPHITE_CONFIGURE) \
-               $(if $(CONFIG_GCC_USE_GRAPHITE),--with-host-libstdcxx=-lstdc++) \
+               --with-host-libstdcxx=-lstdc++ \
                $(SOFT_FLOAT_CONFIG_OPTION) \
                $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
                $(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 --with-abi=64) \
                $(if $(CONFIG_GCC_VERSION_LLVM),--enable-llvm=$(BUILD_DIR_BASE)/host/llvm) \
-               $(if $(CONFIG_GCC_VERSION_4_3_3_CS)$(CONFIG_GCC_VERSION_4_4_1_CS)$(CONFIG_GCC_VERSION_4_4_3_CS),--enable-poison-system-directories)
+               $(if $(CONFIG_sparc),--with-long-double-128) \
 
-ifneq ($(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4)$(CONFIG_GCC_VERSION_4_5),)
+ifeq ($(CONFIG_GCC_LLVM),)
   GCC_BUILD_TARGET_LIBGCC:=y
   GCC_CONFIGURE+= \
                --with-gmp=$(TOPDIR)/staging_dir/host \
                --with-mpfr=$(TOPDIR)/staging_dir/host \
                --disable-decimal-float
+  ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
+    GCC_CONFIGURE += --with-mips-plt
+  endif
 endif
 
-ifneq ($(CONFIG_GCC_VERSION_4_5),)
-  GCC_BUILD_TARGET_LIBGCC:=y
+ifneq ($(CONFIG_GCC_VERSION_4_5)$(CONFIG_GCC_VERSION_4_6),)
   GCC_CONFIGURE+= \
-                --with-gmp=$(TOPDIR)/staging_dir/host \
-                --with-mpc=$(TOPDIR)/staging_dir/host \
-                --with-mpfr=$(TOPDIR)/staging_dir/host \
-                --disable-decimal-float
+               --with-mpc=$(TOPDIR)/staging_dir/host
 endif
 
 ifneq ($(CONFIG_SSP_SUPPORT),)
@@ -153,6 +161,10 @@ ifneq ($(CONFIG_EXTRA_TARGET_ARCH),)
                --enable-targets=$(call qstrip,$(CONFIG_EXTRA_TARGET_ARCH_NAME))-linux-$(TARGET_SUFFIX)
 endif
 
+ifdef CONFIG_sparc
+  GCC_CONFIGURE+= --enable-targets=all
+endif
+
 ifeq ($(LIBC),uClibc)
   GCC_CONFIGURE+= \
                --disable-__cxa_atexit
@@ -161,13 +173,14 @@ else
                --enable-__cxa_atexit
 endif
 
-ifdef CONFIG_powerpc
-  TARGET_CFLAGS := $(patsubst -Os,-O2,$(TARGET_CFLAGS))
+ifneq ($(GCC_ARCH),)
+  GCC_CONFIGURE+= --with-arch=$(GCC_ARCH)
 endif
 
 GCC_MAKE:= \
        export SHELL="$(BASH)"; \
        $(MAKE) \
+               CFLAGS="$(HOST_CFLAGS)" \
                CFLAGS_FOR_TARGET="$(TARGET_CFLAGS)" \
                CXXFLAGS_FOR_TARGET="$(TARGET_CFLAGS)"
 
@@ -187,7 +200,7 @@ define Host/Clean
                $(STAGING_DIR_HOST)/stamp/.binutils_* \
                $(GCC_BUILD_DIR) \
                $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME) \
-               $(TOOLCHAIN_DIR)/usr/$(REAL_GNU_TARGET_NAME) \
-               $(TOOLCHAIN_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-gc* \
-               $(TOOLCHAIN_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-c*
+               $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME) \
+               $(TOOLCHAIN_DIR)/bin/$(REAL_GNU_TARGET_NAME)-gc* \
+               $(TOOLCHAIN_DIR)/bin/$(REAL_GNU_TARGET_NAME)-c*
 endef