gcc-linaro-4.6: update to 2012.12
[openwrt/openwrt.git] / toolchain / gcc / common.mk
index 8b7453335070b1474cb7dbfedd37c5015efcbf53..92873a022976f3a3bbcb5aa7fc363774b870fed3 100644 (file)
@@ -2,7 +2,7 @@
 # Copyright (C) 2002-2003 Erik Andersen <andersen@uclibc.org>
 # Copyright (C) 2004 Manuel Novoa III <mjn3@uclibc.org>
 # Copyright (C) 2005-2006 Felix Fietkau <nbd@openwrt.org>
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -38,16 +38,22 @@ ifdef CONFIG_GCC_VERSION_LLVM
 else
 ifeq ($(findstring linaro, $(CONFIG_GCC_VERSION)),linaro)
     ifeq ($(CONFIG_GCC_VERSION),"4.5-linaro")
-      PKG_REV:=4.5-2011.08
+      PKG_REV:=4.5-2012.03
       PKG_VERSION:=4.5.4
       PKG_VERSION_MAJOR:=4.5
-      PKG_MD5SUM:=c3374e210209e35ad1ea175223d3605c
+      PKG_MD5SUM:=0c25f93e15e362e352c933e4649a7fc6
     endif
     ifeq ($(CONFIG_GCC_VERSION),"4.6-linaro")
-      PKG_REV:=4.6-2011.08
-      PKG_VERSION:=4.6.2
+      PKG_REV:=4.6-2012.12
+      PKG_VERSION:=4.6.4
       PKG_VERSION_MAJOR:=4.6
-      PKG_MD5SUM:=7417cdb33d7b3a18552b2003a98cadfc
+      PKG_MD5SUM:=6b6c6a4faa026edd1193cf6426309039
+    endif
+    ifeq ($(CONFIG_GCC_VERSION),"4.7-linaro")
+      PKG_REV:=4.7-2012.12
+      PKG_VERSION:=4.7.3
+      PKG_VERSION_MAJOR:=4.7
+      PKG_MD5SUM:=247b15687358bc7958eeb91ab22637d1
     endif
     PKG_SOURCE_URL:=http://launchpad.net/gcc-linaro/$(PKG_VERSION_MAJOR)/$(PKG_REV)/+download/
     PKG_SOURCE:=$(PKG_NAME)-linaro-$(PKG_REV).tar.bz2
@@ -57,11 +63,17 @@ else
   PKG_SOURCE_URL:=@GNU/gcc/gcc-$(PKG_VERSION)
   PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 
-  ifeq ($(PKG_VERSION),4.4.6)
-    PKG_MD5SUM:=ab525d429ee4425050a554bc9247d6c4
+  ifeq ($(PKG_VERSION),4.4.7)
+    PKG_MD5SUM:=295709feb4441b04e87dea3f1bab4281
+  endif
+  ifeq ($(PKG_VERSION),4.6.2)
+    PKG_MD5SUM:=028115c4fbfb6cfd75d6369f4a90d87e
+  endif
+  ifeq ($(PKG_VERSION),4.6.3)
+    PKG_MD5SUM:=773092fe5194353b02bb0110052a972e
   endif
-  ifeq ($(PKG_VERSION),4.6.1)
-    PKG_MD5SUM:=c57a9170c677bf795bdc04ed796ca491
+  ifeq ($(PKG_VERSION),4.7.2)
+    PKG_MD5SUM:=cc308a0891e778cfda7a151ab8a6e762
   endif
 endif
 endif
@@ -70,6 +82,8 @@ PATCH_DIR=../patches/$(GCC_VERSION)
 
 BUGURL=https://dev.openwrt.org/
 
+HOST_BUILD_PARALLEL:=1
+
 include $(INCLUDE_DIR)/toolchain-build.mk
 
 HOST_SOURCE_DIR:=$(HOST_BUILD_DIR)
@@ -112,6 +126,7 @@ GCC_CONFIGURE:= \
                $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
                $(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 --with-abi=64) \
                $(if $(CONFIG_GCC_VERSION_LLVM),--enable-llvm=$(BUILD_DIR_BASE)/host/llvm) \
+               $(if $(CONFIG_sparc),--with-long-double-128) \
 
 ifeq ($(CONFIG_GCC_LLVM),)
   GCC_BUILD_TARGET_LIBGCC:=y
@@ -155,17 +170,14 @@ else
                --enable-__cxa_atexit
 endif
 
-ifdef CONFIG_powerpc
-  TARGET_CFLAGS := $(patsubst -Os,-O2,$(TARGET_CFLAGS))
-endif
-
 ifneq ($(GCC_ARCH),)
   GCC_CONFIGURE+= --with-arch=$(GCC_ARCH)
 endif
 
 GCC_MAKE:= \
        export SHELL="$(BASH)"; \
-       $(MAKE) $(TOOLCHAIN_JOBS) \
+       $(MAKE) \
+               CFLAGS="$(HOST_CFLAGS)" \
                CFLAGS_FOR_TARGET="$(TARGET_CFLAGS)" \
                CXXFLAGS_FOR_TARGET="$(TARGET_CFLAGS)"