toolchain: allow choosing the MIPS64 user-land ABI
[openwrt/openwrt.git] / toolchain / gcc / common.mk
index 8305aa9fc14947a20accdf9e0d48a4830836e152..c6b961735ce45bc2173b54b3b0cb4c071781d573 100644 (file)
@@ -113,7 +113,8 @@ GCC_CONFIGURE:= \
                --with-host-libstdcxx=-lstdc++ \
                $(SOFT_FLOAT_CONFIG_OPTION) \
                $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
-               $(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 --with-abi=64) \
+               $(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 \
+                       --with-abi=$(subst ",,$(CONFIG_MIPS64_ABI))) \
                --with-gmp=$(TOPDIR)/staging_dir/host \
                --with-mpfr=$(TOPDIR)/staging_dir/host \
                --disable-decimal-float