build: remove old kernel-headers build directories
[openwrt/openwrt.git] / toolchain / kernel-headers / Makefile
index 75bf221efc567d0ebfd4226e3c161acf2ac93ce7..1bf5598d6fd6287fb3d660d6faf311f017508e32 100644 (file)
@@ -19,10 +19,10 @@ PKG_VERSION:=$(LINUX_VERSION)
 PKG_SOURCE:=$(LINUX_SOURCE)
 PKG_SOURCE_URL:=$(LINUX_SITE)
 HOST_BUILD_DIR:=$(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)
-PKG_MD5SUM:=$(LINUX_KERNEL_MD5SUM)
+PKG_HASH:=$(LINUX_KERNEL_HASH)
 LINUX_DIR := $(HOST_BUILD_DIR)
 FILES_DIR := 
-PATCH_DIR := ./patches$(if $(wildcard ./patches-$(KERNEL_PATCHVER)),-$(KERNEL_PATCHVER))
+PATCH_DIR := ./patches$(if $(wildcard ./patches-$(LINUX_VERSION)),-$(LINUX_VERSION))
 
 include $(INCLUDE_DIR)/toolchain-build.mk
 include $(INCLUDE_DIR)/kernel-defaults.mk
@@ -31,11 +31,12 @@ ifeq ($(strip $(BOARD)),uml)
   LINUX_KARCH:=$(subst x86_64,x86,$(subst i386,x86,$(ARCH)))
 endif
 
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.18)),1)
-  LINUX_HAS_HEADERS_INSTALL:=y
-endif
+HOST_EXTRACFLAGS=
+
+LINUX_HAS_HEADERS_INSTALL:=y
 
 KMAKE := $(MAKE) -C $(HOST_BUILD_DIR) \
+       HOSTCFLAGS="$(HOST_CFLAGS) -Wall -Wmissing-prototypes -Wstrict-prototypes" \
        ARCH=$(LINUX_KARCH) \
        CC="$(KERNEL_CC)" \
        CFLAGS="$(TARGET_CFLAGS)" \
@@ -43,74 +44,45 @@ KMAKE := $(MAKE) -C $(HOST_BUILD_DIR) \
        KBUILD_HAVE_NLS=no \
        CONFIG_SHELL=$(BASH)
 
-ifneq ($(LINUX_HAS_HEADERS_INSTALL),)
-  define Host/Prepare/all
-       mkdir -p $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr
+define Host/Configure/all
+       mkdir -p $(BUILD_DIR_TOOLCHAIN)/linux-dev
        $(KMAKE) \
-               INSTALL_HDR_PATH="$(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/" \
+               INSTALL_HDR_PATH="$(BUILD_DIR_TOOLCHAIN)/linux-dev/" \
                headers_install
-       if [ -d $(HOST_BUILD_DIR)/arch/$(LINUX_KARCH)/include/asm ]; then \
-               mkdir -p $(HOST_BUILD_DIR)/include/asm-$(LINUX_KARCH); \
-               $(CP) \
-                       $(HOST_BUILD_DIR)/arch/$(LINUX_KARCH)/include/asm/. \
-                       $(HOST_BUILD_DIR)/include/asm-$(LINUX_KARCH)/; \
-       fi
-  endef
-else
-  define Host/Prepare/all
-       $(KMAKE) include/linux/version.h include/asm
-       mkdir -p $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include
-       cp -pLR $(HOST_BUILD_DIR)/include/asm $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/
-       cp -pLR $(HOST_BUILD_DIR)/include/asm-generic $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/
-       cp -pLR $(HOST_BUILD_DIR)/include/asm-$(LINUX_KARCH) $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/
-       cp -pLR $(HOST_BUILD_DIR)/include/linux $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/
-  endef
-endif
-
-# XXX: the following is needed to build lzma-loader
-define Host/Prepare/lzma
-       $(CP) \
-               $(HOST_BUILD_DIR)/include/asm-mips/asm.h \
-               $(HOST_BUILD_DIR)/include/asm-mips/regdef.h \
-               $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/asm/
 endef
 
-define Host/Prepare/post/cris
-       $(CP) \
-               $(HOST_BUILD_DIR)/include/linux/user.h \
-               $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/linux/
-       ln -snf $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/arch-v10/arch \
-               $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/arch
-       $(SED) '/#include <asm\/page\.h>/d' $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/asm/user.h
-endef
-
-define Host/Prepare/post/ubicom32
+# XXX: the following is needed to build lzma-loader
+ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
+  define Host/Configure/lzma
        $(CP) \
-               $(HOST_BUILD_DIR)/arch/ubicom32/include/asm/elf.h \
-               $(HOST_BUILD_DIR)/arch/ubicom32/include/asm/user.h \
-               $(HOST_BUILD_DIR)/arch/ubicom32/include/asm/page.h \
-               $(HOST_BUILD_DIR)/arch/ubicom32/include/asm/page_offset.h \
-               $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/asm/
-endef
+               $(HOST_BUILD_DIR)/arch/mips/include/asm/asm.h \
+               $(HOST_BUILD_DIR)/arch/mips/include/asm/regdef.h \
+               $(HOST_BUILD_DIR)/arch/mips/include/asm/asm-eva.h \
+               $(BUILD_DIR_TOOLCHAIN)/linux-dev/include/asm/
+  endef
+endif
 
-define Host/Prepare/post/mips
-       $(call Host/Prepare/lzma)
+define Host/Configure/post/mips
+       $(call Host/Configure/lzma)
 endef
 
-define Host/Prepare/post/mipsel
-       $(call Host/Prepare/lzma)
+define Host/Configure/post/mipsel
+       $(call Host/Configure/lzma)
 endef
 
 define Host/Prepare
+       rm -rf $(BUILD_DIR_TOOLCHAIN)/linux-*
        $(call Kernel/Prepare/Default)
-       ln -sf linux-$(LINUX_VERSION) $(BUILD_DIR_TOOLCHAIN)/linux
+       rm -f $(BUILD_DIR_TOOLCHAIN)/linux
+       ln -s linux-$(LINUX_VERSION) $(BUILD_DIR_TOOLCHAIN)/linux
        $(SED) 's/@expr length/@-expr length/' $(HOST_BUILD_DIR)/Makefile
-       yes '' | $(KMAKE) oldconfig
-       $(call Host/Prepare/all)
-       $(call Host/Prepare/post/$(ARCH))
 endef
 
 define Host/Configure
+       env
+       yes '' | $(KMAKE) oldconfig
+       $(call Host/Configure/all)
+       $(call Host/Configure/post/$(ARCH))
 endef
 
 define Host/Compile