kernel: fix portability issues on the x86 specific relocs host tool, fixes build...
[openwrt/openwrt.git] / toolchain / kernel-headers / Makefile
index ca8a78ff162ea36e4ebee6472d266184b9a1e7a6..7f0962ef9de7aeaf47e9d2dd02c916e21903c6ac 100644 (file)
@@ -36,6 +36,7 @@ HOST_EXTRACFLAGS=
 LINUX_HAS_HEADERS_INSTALL:=y
 
 KMAKE := $(MAKE) -C $(HOST_BUILD_DIR) \
+       HOSTCFLAGS="$(HOST_CFLAGS) -Wall -Wmissing-prototypes -Wstrict-prototypes" \
        ARCH=$(LINUX_KARCH) \
        CC="$(KERNEL_CC)" \
        CFLAGS="$(TARGET_CFLAGS)" \