gmp: upgrade to version 5.1.2
[openwrt/openwrt.git] / toolchain / kernel-headers / Makefile
index 37f87dd37b4b654d784294ac4b372e71b857874e..9427f82c7a81abde238d04093951e7270d813eef 100644 (file)
@@ -21,111 +21,74 @@ PKG_SOURCE_URL:=$(LINUX_SITE)
 HOST_BUILD_DIR:=$(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)
 PKG_MD5SUM:=$(LINUX_KERNEL_MD5SUM)
 LINUX_DIR := $(HOST_BUILD_DIR)
+FILES_DIR := 
+PATCH_DIR := ./patches$(if $(wildcard ./patches-$(LINUX_VERSION)),-$(LINUX_VERSION))
 
 include $(INCLUDE_DIR)/toolchain-build.mk
 include $(INCLUDE_DIR)/kernel-defaults.mk
 
 ifeq ($(strip $(BOARD)),uml)
-  LINUX_KARCH:=$(ARCH)
+  LINUX_KARCH:=$(subst x86_64,x86,$(subst i386,x86,$(ARCH)))
 endif
 
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.18)),1)
-  LINUX_HAS_HEADERS_INSTALL:=y
-endif
+HOST_EXTRACFLAGS=
+
+LINUX_HAS_HEADERS_INSTALL:=y
 
 KMAKE := $(MAKE) -C $(HOST_BUILD_DIR) \
+       HOSTCFLAGS="$(HOST_CFLAGS) -Wall -Wmissing-prototypes -Wstrict-prototypes" \
        ARCH=$(LINUX_KARCH) \
+       CC="$(KERNEL_CC)" \
+       CFLAGS="$(TARGET_CFLAGS)" \
+       CROSS_COMPILE=$(TARGET_CROSS) \
        KBUILD_HAVE_NLS=no \
        CONFIG_SHELL=$(BASH)
 
-define Host/Prepare/pre/cris
-       ln -sf $(HOST_BUILD_DIR)/include/asm-cris/arch-v10 $(HOST_BUILD_DIR)/include/asm-cris/arch
-       ln -sf $(HOST_BUILD_DIR)/include/asm-cris/arch-v10 $(HOST_BUILD_DIR)/arch/cris/arch
-endef
-
-define Host/Prepare/pre/powerpc
-       if [ -d $(HOST_BUILD_DIR)/include/asm-ppc ]; then \
-               mkdir -p $(PKG_BUILD_DIR)/include/asm-powerpc/; \
-               $(CP) $(HOST_BUILD_DIR)/include/asm-ppc/* $(HOST_BUILD_DIR)/include/asm-powerpc/; \
-               rm -rf $(HOST_BUILD_DIR)/include/asm-ppc; \
-               ln -s $(HOST_BUILD_DIR)/include/asm-powerpc $(HOST_BUILD_DIR)/include/asm-ppc; \
-       fi
-endef
-
-ifneq ($(LINUX_HAS_HEADERS_INSTALL),)
-  define Host/Prepare/all
-       mkdir -p $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr
+define Host/Configure/all
+       mkdir -p $(BUILD_DIR_TOOLCHAIN)/linux-dev
        $(KMAKE) \
-               CROSS_COMPILE=$(TARGET_CROSS) \
-               INSTALL_HDR_PATH="$(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/" \
+               INSTALL_HDR_PATH="$(BUILD_DIR_TOOLCHAIN)/linux-dev/" \
                headers_install
-  endef
-else
-  define Host/Prepare/all
-       mkdir -p $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include
-       cp -pLR $(HOST_BUILD_DIR)/include/asm $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/
-       cp -pLR $(HOST_BUILD_DIR)/include/asm-generic $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/
-       cp -pLR $(HOST_BUILD_DIR)/include/asm-$(LINUX_KARCH) $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/
-       cp -pLR $(HOST_BUILD_DIR)/include/linux $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/
-  endef
-endif
+endef
 
 # XXX: the following is needed to build lzma-loader
-define Host/Prepare/lzma
+ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
+  define Host/Configure/lzma
        $(CP) \
-               $(HOST_BUILD_DIR)/include/asm-mips/asm.h \
-               $(HOST_BUILD_DIR)/include/asm-mips/regdef.h \
-               $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/asm/
-endef
+               $(HOST_BUILD_DIR)/arch/mips/include/asm/asm.h \
+               $(HOST_BUILD_DIR)/arch/mips/include/asm/regdef.h \
+               $(BUILD_DIR_TOOLCHAIN)/linux-dev/include/asm/
+  endef
+endif
 
-# XXX: the following are needed to build a cris toolchain
-define Host/Prepare/post/cris
+define Host/Configure/post/cris
        $(CP) \
                $(HOST_BUILD_DIR)/include/linux/user.h \
-               $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/linux/
-       $(CP) \
-               $(HOST_BUILD_DIR)/include/asm-cris/elf.h \
-               $(HOST_BUILD_DIR)/include/asm-cris/page.h \
-               $(HOST_BUILD_DIR)/include/asm-cris/user.h \
-               $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/asm/
-       mkdir -p $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/asm/arch
-       $(CP) \
-               $(HOST_BUILD_DIR)/include/asm-cris/arch/elf.h \
-               $(HOST_BUILD_DIR)/include/asm-cris/arch/page.h \
-               $(HOST_BUILD_DIR)/include/asm-cris/arch/ptrace.h \
-               $(HOST_BUILD_DIR)/include/asm-cris/arch/user.h \
-               $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/asm/arch/
-       $(CP) \
-               $(HOST_BUILD_DIR)/include/asm-generic/memory_model.h \
-               $(HOST_BUILD_DIR)/include/asm-generic/page.h \
-               $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/asm-generic/
+               $(BUILD_DIR_TOOLCHAIN)/linux-dev/include/linux/
+       ln -snf $(BUILD_DIR_TOOLCHAIN)/linux-dev/include/arch-v10/arch \
+               $(BUILD_DIR_TOOLCHAIN)/linux-dev/include/arch
+       $(SED) '/#include <asm\/page\.h>/d' $(BUILD_DIR_TOOLCHAIN)/linux-dev/include/asm/user.h
 endef
 
-define Host/Prepare/post/mips
-       $(call Host/Prepare/lzma)
+define Host/Configure/post/mips
+       $(call Host/Configure/lzma)
 endef
 
-define Host/Prepare/post/mipsel
-       $(call Host/Prepare/lzma)
+define Host/Configure/post/mipsel
+       $(call Host/Configure/lzma)
 endef
 
 define Host/Prepare
        $(call Kernel/Prepare/Default)
        ln -sf linux-$(LINUX_VERSION) $(BUILD_DIR_TOOLCHAIN)/linux
        $(SED) 's/@expr length/@-expr length/' $(HOST_BUILD_DIR)/Makefile
-       yes '' | $(KMAKE) oldconfig
-       $(KMAKE) include/linux/version.h include/asm
-       if [ -d $(HOST_BUILD_DIR)/arch/$(LINUX_KARCH)/include/asm ]; then \
-               $(CP) \
-                       $(HOST_BUILD_DIR)/arch/$(LINUX_KARCH)/include/asm/. \
-                       $(HOST_BUILD_DIR)/include/asm-$(LINUX_KARCH)/; \
-       fi
-       $(call Host/Prepare/pre/$(ARCH))
-       $(call Host/Prepare/all)
-       $(call Host/Prepare/post/$(ARCH))
 endef
 
 define Host/Configure
+       env
+       yes '' | $(KMAKE) oldconfig
+       $(call Host/Configure/all)
+       $(call Host/Configure/post/$(ARCH))
 endef
 
 define Host/Compile