add a heavily cleaned up version of ubicom32 toolchain support
[openwrt/openwrt.git] / toolchain / kernel-headers / Makefile
index ff2ce2331a4f74d5d73910e7ab2558008203ca97..e82a4c8104ce040f0f482054d470bf6b7624a951 100644 (file)
@@ -115,6 +115,15 @@ else
   endef
 endif
 
+define Host/Prepare/post/ubicom32
+       $(CP) \
+               $(HOST_BUILD_DIR)/arch/ubicom32/include/asm/elf.h \
+               $(HOST_BUILD_DIR)/arch/ubicom32/include/asm/user.h \
+               $(HOST_BUILD_DIR)/arch/ubicom32/include/asm/page.h \
+               $(HOST_BUILD_DIR)/arch/ubicom32/include/asm/page_offset.h \
+               $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/asm/
+endef
+
 define Host/Prepare/post/mips
        $(call Host/Prepare/lzma)
 endef