toolchain/glibc: update to latest 2.26 commit
[openwrt/openwrt.git] / toolchain / uClibc / Makefile
index 545ea5ae563e420e93ce770d52feae06af36678b..4764f2fa1d70f66e98212085d1398b6190944330 100644 (file)
@@ -16,26 +16,22 @@ endef
 
 define Host/Compile
        $(SED) 's,^CROSS=.*,CROSS=$(TARGET_CROSS),g' $(HOST_BUILD_DIR)/Rules.mak
-       $(UCLIBC_MAKE) $(TOOLCHAIN_JOBS) PREFIX= all
+       $(UCLIBC_MAKE) PREFIX= all
 endef
 
 define Host/Install
        $(call Host/SetToolchainInfo)
        $(UCLIBC_MAKE) PREFIX="$(TOOLCHAIN_DIR)/" install_runtime install_dev
        $(CP) $(HOST_BUILD_DIR)/libc/libc_so.a $(TOOLCHAIN_DIR)/lib/
-       $(CP) $(HOST_BUILD_DIR)/libpthread/*/libpthread_so.a $(TOOLCHAIN_DIR)/lib/
        ( cd $(TOOLCHAIN_DIR) ; \
                for d in lib usr/lib ; do \
-                 for f in libc.so libpthread.so libgcc_s.so ; do \
+                 for f in libc.so libgcc_s.so ; do \
                    if [ -f $$$$d/$$$$f -a ! -L $$$$d/$$$$f ] ; then \
                      $(SED) 's,/usr/lib/,,g;s,/lib/,,g' $$$$d/$$$$f ; \
                    fi \
                  done \
                done \
        )
-       rm -f \
-               $(TOOLCHAIN_DIR)/lib/libresolv*.so* \
-               $(TOOLCHAIN_DIR)/lib/libnsl*.so*
 endef
 
 $(eval $(call HostBuild))