toolchain/uClibc: handle different MIPS64 ABIs
[openwrt/openwrt.git] / toolchain / uClibc / common.mk
index e84c02a1623a7e9b138ffd80b58dddd5969e2275..dec4a1c741f825d949745f24a535776d9f095e1c 100644 (file)
@@ -42,7 +42,8 @@ GEN_CONFIG=$(SCRIPT_DIR)/kconfig.pl -n \
        $(if $(CONFIG_UCLIBC_ENABLE_DEBUG),$(if $(wildcard $(CONFIG_DIR)/debug),'+' $(CONFIG_DIR)/debug)) \
        $(CONFIG_DIR)/$(ARCH)$(strip \
                $(if $(wildcard $(CONFIG_DIR)/$(ARCH).$(BOARD)),.$(BOARD), \
-                       $(if $(CONFIG_HAS_SPE_FPU),$(if $(wildcard $(CONFIG_DIR)/$(ARCH).e500),.e500))))
+                       $(if $(CONFIG_MIPS64_ABI),.$(subst ",,$(CONFIG_MIPS64_ABI)), \
+                       $(if $(CONFIG_HAS_SPE_FPU),$(if $(wildcard $(CONFIG_DIR)/$(ARCH).e500),.e500)))))
 
 TARGET_CFLAGS := $(filter-out -mips16,$(TARGET_CFLAGS))