added our own pkg-config wrapper, making the sed foo on *.pc files obselete 1/2
[openwrt/openwrt.git] / tools / Makefile
index 0d6b51597732d3a81d9688c2c702fb614a85a67c..ecab9dae84fb467ac4a80db3d3ba4b7934f11f1c 100644 (file)
@@ -6,23 +6,32 @@
 #
 # Main makefile for the host tools
 #
-
-curdir:=$(patsubst %/Makefile,%,$(lastword $(MAKEFILE_LIST)))
+curdir:=tools
 
 # subdirectories to descend into
-$(curdir)/builddirs := sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline $(if $(CONFIG_CCACHE),ccache)
+$(curdir)/builddirs := sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config $(if $(CONFIG_CCACHE),ccache)
 
 # builddir dependencies
 $(curdir)/squashfs/compile := $(curdir)/lzma/install
 
 # preparatory work
-$(STAGING_DIR)/include-host/.done:
-       @mkdir -p $$(dirname $@)
-       @cp $(curdir)/include/*.h $$(dirname $@)/
-       @touch $@
+$(STAGING_DIR)/.prepared: $(TMP_DIR)/.build
+       @for dir in $(STAGING_DIR) $(STAGING_DIR_HOST); do ( \
+               set -x; \
+               mkdir -p "$$dir"; \
+               cd "$$dir"; \
+               mkdir -p bin lib include stamp; \
+       ); done
+       mkdir -p $(BUILD_DIR_HOST)/stamp $(BUILD_DIR)/stamp
+       $(INSTALL_DATA) $(TOPDIR)/tools/include/*.h $(STAGING_DIR_HOST)/include/
+       touch $@
+
+$(curdir)//prepare = $(STAGING_DIR)/.prepared
+$(curdir)//compile = $(STAGING_DIR)/.prepared
 
 # prerequisites for the individual targets
-$(curdir)/ := .config
-$(curdir)//prepare := $(STAGING_DIR)/include-host/.done
-$(eval $(call stampfile,$(curdir),tools))
+$(curdir)/ := .config prereq
+$(curdir)//install = $(1)/compile
+
+$(eval $(call stampfile,$(curdir),tools,install))
 $(eval $(call subdir,$(curdir)))