autoconf: portability fixes
[openwrt/openwrt.git] / tools / autoconf / Makefile
index f5d22c3ff85fa04c3b3e88dc19732ed4d13df96f..c45855c03d5a877ee6523ab91cd2a6501b60a2e0 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,19 +7,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=autoconf
-PKG_VERSION:=2.68
+PKG_VERSION:=2.69
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/autoconf
-PKG_MD5SUM:=864d785215aa60d627c91fcb21b05b07
+PKG_MD5SUM:=50f97f4159805e374639a73e2636f22e
 
 include $(INCLUDE_DIR)/host-build.mk
 
-define Host/Configure
-       $(call Host/Configure/Default,\
-               --datarootdir=$(STAGING_DIR_HOST)/share \
-       )
-endef
+HOST_CONFIGURE_ARGS += \
+       --datarootdir=$(STAGING_DIR_HOST)/share
+
+HOST_CONFIGURE_VARS += \
+       PERL="/usr/bin/env perl"
 
 define Host/Compile
        export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR)