bison: replace the yacc script with one that does not hardcode the path (fixes #20605)
[openwrt/openwrt.git] / tools / bison / Makefile
index 01820e2755009d4d53656c5175e5b471fbdbff50..256512116f9f7b8f90f2dcce24846286e5c50025 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,12 +7,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bison
-PKG_VERSION:=2.4.3
+PKG_VERSION:=3.0.2
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
-PKG_MD5SUM:=c1d3ea81bc370dbd43b6f0b2cd21287e
-PKG_CAT:=bzcat
+PKG_MD5SUM:=146be9ff9fbd27497f0bf2286a5a2082
+PKG_CAT:=xzcat
+
+HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
@@ -21,4 +23,9 @@ define Host/Clean
        $(call Host/Clean/Default)
 endef
 
+define Host/Install
+       $(call Host/Install/Default)
+       $(INSTALL_BIN) ./scripts/yacc $(STAGING_DIR_HOST)/bin/yacc
+endef
+
 $(eval $(call HostBuild))