tools/bison: Update to 3.2.2
[openwrt/openwrt.git] / tools / bison / Makefile
index b7fdf254a27b10bf85e9ae4a07b9bb62866cefc1..d00e7240d637c0f31268d0a9fe7f730b13e12fd4 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2008-2012 OpenWrt.org
+#
+# Copyright (C) 2008-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,20 +7,24 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bison
-PKG_VERSION:=2.5
+PKG_VERSION:=3.2.2
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
-PKG_MD5SUM:=9dba20116b13fc61a0846b0058fbe004
-PKG_CAT:=bzcat
+PKG_HASH:=6f950f24e4d0745c7cc870e36d04f4057133ce0f31d6b4564e6f510a7d3ffafa
 
-include $(INCLUDE_DIR)/host-build.mk
+HOST_BUILD_PARALLEL:=1
 
-HOST_LDFLAGS += -static
+include $(INCLUDE_DIR)/host-build.mk
 
 define Host/Clean
        -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
        $(call Host/Clean/Default)
 endef
 
+define Host/Install
+       $(call Host/Install/Default)
+       $(INSTALL_BIN) ./scripts/yacc $(STAGING_DIR_HOST)/bin/yacc
+endef
+
 $(eval $(call HostBuild))