ccache, samba36: fix samba.org addresses to use https
[openwrt/openwrt.git] / tools / ccache / Makefile
index 471922c88f103112554786410782eebd49f6b6fc..1ff63e7630de76aa6a655c79011c8ce89c97d3d3 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,40 +8,29 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/target.mk
 
 PKG_NAME:=ccache
-PKG_VERSION:=2.4
+PKG_VERSION:=3.3.2
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://samba.org/ftp/ccache/
-PKG_MD5SUM:=73c1ed1e767c1752dd0f548ec1e66ce7
-PKG_CAT:=zcat
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=https://download.samba.org/pub/ccache/ \
+               https://samba.org/ftp/ccache/
+PKG_HASH:=907685cb23d8f82074b8d1a9b4ebabb36914d151ac7b96a840c68c08d1a14530
 
 include $(INCLUDE_DIR)/host-build.mk
 
-ifneq ($(strip $(shell which ccache >/dev/null && echo found)),found)
-  define Build/Compile
-       $(MAKE) CC="$(HOSTCC)" -C $(PKG_BUILD_DIR)
-  endef
+HOST_CONFIGURE_VARS += CC="$(HOSTCC_NOCACHE)"
 
-  define Build/Install
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(STAGING_DIR_HOST)" \
-               install
-  endef
+define Host/Install/ccache
+       $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/
+       $(CP) ./files/* $(STAGING_DIR_HOST)/bin/
+endef
 
-  define Build/Clean
-       -$(MAKE) -C $(PKG_BUILD_DIR) uninstall
-       -$(MAKE) -C $(PKG_BUILD_DIR) clean
-       $(call Build/Clean/Default)
-  endef
-else
-  define Build/Prepare
-  endef
-  define Build/Configure
-  endef
-  define Build/Compile
-  endef
-  define Build/Clean
-  endef
-endif
+define Host/Clean
+       -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+       $(call Host/Clean/Default)
+endef
+define Host/Install
+       $(call Host/Install/Default)
+       $(call Host/Install/ccache)
+endef
 
 $(eval $(call HostBuild))