tools/ccache: Update ccache 3.3.2 and refresh patch
[openwrt/openwrt.git] / tools / ccache / Makefile
index 9020c9c47b64d81c6ee0f9ca7c77dbfdb10fcfef..2dbf03ce82e77c0b4af1407c934d1ec811866027 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,15 +8,14 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/target.mk
 
 PKG_NAME:=ccache
-PKG_VERSION:=3.1.7
+PKG_VERSION:=3.3.2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://samba.org/ftp/ccache/
-PKG_MD5SUM:=80a698c22d0b06b19c88ac58e8d8b632
+PKG_MD5SUM:=2767d8f88f5ec218983a2f05c9e20df2
 
 include $(INCLUDE_DIR)/host-build.mk
 
-HOST_LDFLAGS += $(HOST_STATIC_LINKING)
 HOST_CONFIGURE_VARS += CC="$(HOSTCC_NOCACHE)"
 
 define Host/Install/ccache
@@ -24,29 +23,13 @@ define Host/Install/ccache
        $(CP) ./files/* $(STAGING_DIR_HOST)/bin/
 endef
 
-ifneq ($(strip $(shell which ccache >/dev/null && echo found)),found)
-  define Host/Clean
+define Host/Clean
        -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
        $(call Host/Clean/Default)
-  endef
-  define Host/Install
+endef
+define Host/Install
        $(call Host/Install/Default)
        $(call Host/Install/ccache)
-  endef
-else
-  define Host/Prepare
-  endef
-  define Host/Configure
-  endef
-  define Host/Compile
-  endef
-  define Host/Install
-       $(call Host/Install/ccache)
-  endef
-  define Host/Clean
-  endef
-  define Download
-  endef
-endif
+endef
 
 $(eval $(call HostBuild))