mpc85xx: fix address config for ws-ap3825i
[openwrt/openwrt.git] / tools / ccache / Makefile
index d91bee19efc4398089eeb690d0901c9905a454e8..cd2c6d27d5e1cd165ca6b2ba8bfb23febc3d2c75 100644 (file)
@@ -1,51 +1,27 @@
-# 
-# Copyright (C) 2006-2013 OpenWrt.org
+#
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/target.mk
 
 PKG_NAME:=ccache
-PKG_VERSION:=3.1.9
+PKG_VERSION:=4.9.1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_SOURCE_URL:=http://samba.org/ftp/ccache/
-PKG_MD5SUM:=522a6016bda56892653612bbdefff3e0
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://github.com/ccache/ccache/releases/download/v$(PKG_VERSION)
+PKG_HASH:=12834ecaaaf2db069dda1d1d991f91c19e3274cc04a471af5b64195def17e90f
 
 include $(INCLUDE_DIR)/host-build.mk
+include $(INCLUDE_DIR)/cmake.mk
 
-HOST_CONFIGURE_VARS += CC="$(HOSTCC_NOCACHE)"
-
-define Host/Install/ccache
-       $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/
-       $(CP) ./files/* $(STAGING_DIR_HOST)/bin/
-endef
-
-ifneq ($(strip $(shell which ccache >/dev/null && echo found)),found)
-  define Host/Clean
-       -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
-       $(call Host/Clean/Default)
-  endef
-  define Host/Install
-       $(call Host/Install/Default)
-       $(call Host/Install/ccache)
-  endef
-else
-  define Host/Prepare
-  endef
-  define Host/Configure
-  endef
-  define Host/Compile
-  endef
-  define Host/Install
-       $(call Host/Install/ccache)
-  endef
-  define Host/Clean
-  endef
-  define Download
-  endef
-endif
+CMAKE_HOST_OPTIONS += \
+       -DCMAKE_C_COMPILER_LAUNCHER="" \
+       -DCMAKE_CXX_COMPILER_LAUNCHER="" \
+       -DCMAKE_SKIP_RPATH=FALSE \
+       -DCMAKE_INSTALL_RPATH="${STAGING_DIR_HOST}/lib" \
+       -DENABLE_DOCUMENTATION=OFF \
+       -DREDIS_STORAGE_BACKEND=OFF
 
 $(eval $(call HostBuild))