cmake: restore parallel build support for bootstrap
[openwrt/openwrt.git] / tools / cmake / Makefile
index a1137c5b506682372ee66639bda86f1f74757fb9..c56cd40fb5a92b5240cacd0138b89d51ff6f65c6 100644 (file)
@@ -20,7 +20,9 @@ HOST_CONFIGURE_PARALLEL:=1
 include $(INCLUDE_DIR)/host-build.mk
 
 HOST_CONFIGURE_CMD := \
 include $(INCLUDE_DIR)/host-build.mk
 
 HOST_CONFIGURE_CMD := \
-       MAKEFLAGS="$(HOST_JOBS)" $(BASH) ./configure
+       MAKEFLAGS="$(HOST_JOBS)" \
+       $(BASH) ./configure \
+               $(if $(MAKE_JOBSERVER),--parallel="$(MAKE_JOBSERVER)")
 
 HOST_CONFIGURE_VARS :=
 
 
 HOST_CONFIGURE_VARS :=