busybox: keep syslog.conf during sysupgrade
[openwrt/openwrt.git] / tools / genext2fs / Makefile
index 78416f2b3e4fceabe915cae3df53fcc30a4f7a3b..3a911df91a46d4f0d95475c7124a1ff1883746e5 100644 (file)
@@ -12,34 +12,31 @@ PKG_VERSION:=1.4.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/genext2fs
-PKG_MD5SUM:=b7b6361bcce2cedff1ae437fadafe53b
+PKG_HASH:=404dbbfa7a86a6c3de8225c8da254d026b17fd288e05cec4df2cc7e1f4feecfc
 
 include $(INCLUDE_DIR)/host-build.mk
 
-define Host/Configure
-       ( cd $(HOST_BUILD_DIR); \
-               ./configure \
-                       --target=$(GNU_HOST_NAME) \
-                       --host=$(GNU_HOST_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --sbindir=/usr/sbin \
-                       --libexecdir=/usr/lib \
-                       --sysconfdir=/etc \
-                       --datadir=/usr/share \
-                       --localstatedir=/var \
-                       --mandir=/usr/man \
-                       --infodir=/usr/info \
-       )
-endef
+HOST_CONFIGURE_ARGS = \
+       --target=$(GNU_HOST_NAME) \
+       --host=$(GNU_HOST_NAME) \
+       --build=$(GNU_HOST_NAME) \
+       --program-prefix="" \
+       --program-suffix="" \
+       --prefix=/usr \
+       --exec-prefix=/usr \
+       --bindir=/usr/bin \
+       --sbindir=/usr/sbin \
+       --libexecdir=/usr/lib \
+       --sysconfdir=/etc \
+       --datadir=/usr/share \
+       --localstatedir=/var \
+       --mandir=/usr/man \
+       --infodir=/usr/info \
 
 define Host/Compile
        $(MAKE) -C $(HOST_BUILD_DIR) \
-               CFLAGS="$(HOST_CFLAGS) -include getline.h" \
+               CFLAGS="$(HOST_CFLAGS)" \
+               LDFLAGS="$(HOST_LDFLAGS)" \
                all
 endef