use HOST_STATIC_LINKING instead of hardcoding -static
[openwrt/openwrt.git] / tools / genext2fs / Makefile
index 2462b8cd8afe502f66cec4eaf6d8bdc8b51911c1..57e8d35b51995c1470dca0735ec9d0276c5f485b 100644 (file)
@@ -36,7 +36,7 @@ HOST_CONFIGURE_ARGS = \
 define Host/Compile
        $(MAKE) -C $(HOST_BUILD_DIR) \
                CFLAGS="$(HOST_CFLAGS)" \
-               LDFLAGS="$(HOST_LDFLAGS) -static" \
+               LDFLAGS="$(HOST_LDFLAGS) $(HOST_STATIC_LINKING)" \
                all
 endef