tools/gmp enable parallel builds
[openwrt/openwrt.git] / tools / gmp / Makefile
index 42646716b5c992bd99fd4c21c87f02ee33df4ef1..292d9a5b3aec2ab62fa77373ddb247f6b33022a8 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,36 +7,22 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gmp
-PKG_VERSION:=4.2.4
+PKG_VERSION:=5.0.5
 
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gmp/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=
+PKG_MD5SUM:=8aef50959acec2a1ad41d144ffe0f3b5
 
-include $(INCLUDE_DIR)/host-build.mk
-
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); \
-       ./configure \
-         --prefix=$(STAGING_DIR_HOST) \
-         --build=$(GNU_HOST_NAME) \
-         --enable-static \
-         --disable-shared \
-         --enable-cxx \
-         --enable-mpbsd \
-       );
-endef
+HOST_BUILD_PARALLEL:=1
 
-define Build/Compile
-       make -C $(PKG_BUILD_DIR) all
-endef
+include $(INCLUDE_DIR)/host-build.mk
 
-define Build/Install
-       make -C $(PKG_BUILD_DIR) install
-endef
+unexport CFLAGS
 
-define Build/Clean
-       rm -rf $(PKG_BUILD_DIR)
-endef
+HOST_CONFIGURE_ARGS += \
+       --enable-static \
+       --disable-shared \
+       --enable-cxx \
+       --enable-mpbsd
 
 $(eval $(call HostBuild))