tools/gmp: Remove obsolete options
[openwrt/openwrt.git] / tools / gmp / Makefile
index 4c6fac425f93eddf7e3c338cca6a892974036772..36d51eb711ad74166845e974f73db517b3140caa 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,36 +7,28 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gmp
-PKG_VERSION:=4.2.4
+PKG_VERSION:=6.2.0
 
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gmp/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=
+PKG_HASH:=258e6cd51b3fbdfc185c716d55f82c08aff57df0c6fbd143cf6ed561267a1526
+
+HOST_FIXUP:=autoreconf
+
+HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
-define Host/Configure
-       (cd $(HOST_BUILD_DIR); \
-       ./configure \
-         --prefix=$(STAGING_DIR_HOST) \
-         --build=$(GNU_HOST_NAME) \
-         --enable-static \
-         --disable-shared \
-         --enable-cxx \
-         --enable-mpbsd \
-       );
-endef
-
-define Host/Compile
-       make -C $(HOST_BUILD_DIR) all
-endef
-
-define Host/Install
-       make -C $(HOST_BUILD_DIR) install
-endef
-
-define Host/Clean
-       rm -rf $(HOST_BUILD_DIR)
-endef
+unexport CFLAGS
+
+HOST_CONFIGURE_ARGS += \
+       --enable-static \
+       --disable-shared \
+       --disable-assembly \
+       --enable-cxx
+
+ifeq ($(GNU_HOST_NAME),x86_64-linux-gnux32)
+HOST_CONFIGURE_ARGS += ABI=x32
+endif
 
 $(eval $(call HostBuild))