gmp: upgrade to version 5.1.2
[openwrt/openwrt.git] / tools / gmp / Makefile
index 3f6e7923989321fc4b5992fbdb8eabaa777238ca..ca80415bc863e5a8f76d3c7577ab6418ac59e5c4 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,34 +7,24 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gmp
-PKG_VERSION:=4.3.1
+PKG_VERSION:=5.1.2
 
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gmp/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=26cec15a90885042dd4a15c4003b08ae
+PKG_MD5SUM:=06fe2ca164221c59ce74867155cfc1ac
+
+HOST_FIXUP:=autoreconf
+
+HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
 unexport CFLAGS
 
-ifeq ($(HOST_OS),Darwin)
-  GNU_HOST_NAME:=
-  HOST_CONFIGURE_ARGS:=$(filter-out --target= --build= --host=,$(HOST_CONFIGURE_ARGS))
-endif
-
 HOST_CONFIGURE_ARGS += \
        --enable-static \
        --disable-shared \
        --enable-cxx \
        --enable-mpbsd
 
-define Host/Configure
-       (cd $(HOST_BUILD_DIR)/$(3); \
-               $(HOST_CONFIGURE_CMD) \
-               $(HOST_CONFIGURE_VARS) \
-               $(HOST_CONFIGURE_ARGS); \
-       )
-endef
-
-
 $(eval $(call HostBuild))