kernel: improve uapi headers coexistence with musl
[openwrt/openwrt.git] / tools / gmp / Makefile
index 42646716b5c992bd99fd4c21c87f02ee33df4ef1..fac05e356820e0d7dd92f567e15b9d9e1d02d928 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,36 +7,29 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gmp
-PKG_VERSION:=4.2.4
+PKG_VERSION:=5.1.3
 
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gmp/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=
+PKG_MD5SUM:=e5fe367801ff067b923d1e6a126448aa
+
+HOST_FIXUP:=autoreconf
+
+HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); \
-       ./configure \
-         --prefix=$(STAGING_DIR_HOST) \
-         --build=$(GNU_HOST_NAME) \
-         --enable-static \
-         --disable-shared \
-         --enable-cxx \
-         --enable-mpbsd \
-       );
-endef
-
-define Build/Compile
-       make -C $(PKG_BUILD_DIR) all
-endef
-
-define Build/Install
-       make -C $(PKG_BUILD_DIR) install
-endef
-
-define Build/Clean
-       rm -rf $(PKG_BUILD_DIR)
-endef
+unexport CFLAGS
+
+HOST_CONFIGURE_ARGS += \
+       --enable-static \
+       --disable-shared \
+       --disable-assembly \
+       --enable-cxx \
+       --enable-mpbsd
+
+ifeq ($(GNU_HOST_NAME),x86_64-linux-gnux32)
+HOST_CONFIGURE_ARGS += ABI=x32
+endif
 
 $(eval $(call HostBuild))