gmp: disable assembly to fix build on systems that use PIE binaries
[openwrt/openwrt.git] / tools / gmp / Makefile
index 463cbe9f5c4f1d47bfa942c3e51299d4bca5f331..fac05e356820e0d7dd92f567e15b9d9e1d02d928 100644 (file)
@@ -24,7 +24,12 @@ unexport CFLAGS
 HOST_CONFIGURE_ARGS += \
        --enable-static \
        --disable-shared \
+       --disable-assembly \
        --enable-cxx \
        --enable-mpbsd
 
+ifeq ($(GNU_HOST_NAME),x86_64-linux-gnux32)
+HOST_CONFIGURE_ARGS += ABI=x32
+endif
+
 $(eval $(call HostBuild))