mkimage: update to 2014.04
[openwrt/openwrt.git] / tools / mkimage / patches / 040-include_order.patch
index 94324666f461b130c5ed8c6e1e984e713d5214e0..f4fbbaf7578d1db1e3ee4137d3dedb1ea5e5c6cd 100644 (file)
@@ -1,14 +1,11 @@
 --- a/tools/Makefile
 +++ b/tools/Makefile
-@@ -165,9 +165,9 @@ NOPEDOBJS := $(addprefix $(obj),$(NOPED_
- # Define __KERNEL_STRICT_NAMES to prevent typedef overlaps
+@@ -173,7 +173,7 @@
+ # Define _GNU_SOURCE to obtain the getline prototype from stdio.h
  #
- HOSTCPPFLAGS =        -include $(SRCTREE)/include/libfdt_env.h \
--              -idirafter $(SRCTREE)/include \
-+              -I $(SRCTREE)/include \
-               -idirafter $(OBJTREE)/include2 \
--              -idirafter $(OBJTREE)/include \
-+              -I $(OBJTREE)/include \
-               -I $(SRCTREE)/lib/libfdt \
-               -I $(SRCTREE)/tools \
+ HOST_EXTRACFLAGS += -include $(srctree)/include/libfdt_env.h \
+-              $(patsubst -I%,-idirafter%, $(UBOOTINCLUDE)) \
++              -I$(srctree)/include \
+               -I$(srctree)/lib/libfdt \
+               -I$(srctree)/tools \
                -DCONFIG_SYS_TEXT_BASE=$(CONFIG_SYS_TEXT_BASE) \