mpfr: upgrade to 3.1.2
[openwrt/openwrt.git] / tools / mpfr / Makefile
index 58a15eb273a6d5e0e52e422b01c305a089eac874..06d92e5bc4202c55829b6deb34a71fc91a37c61e 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,35 +7,20 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mpfr
-PKG_VERSION:=2.3.2
+PKG_VERSION:=3.1.2
 
-PKG_SOURCE_URL:=http://www.mpfr.org/mpfr-2.3.2
+PKG_SOURCE_URL:=http://www.mpfr.org/mpfr-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=527147c097874340cb9cee0579dacf3b
+PKG_MD5SUM:=ee2c3ac63bf0c2359bf08fc3ee094c19
 
-include $(INCLUDE_DIR)/host-build.mk
-
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); \
-       ./configure \
-         --prefix=$(STAGING_DIR_HOST) \
-         --build=$(GNU_HOST_NAME) \
-         --enable-static \
-         --disable-shared \
-         --with-gmp=$(STAGING_DIR_HOST) \
-       );
-endef
+HOST_BUILD_PARALLEL:=1
+HOST_FIXUP:=autoreconf
 
-define Build/Compile
-       make -C $(PKG_BUILD_DIR) all
-endef
-
-define Build/Install
-       make -C $(PKG_BUILD_DIR) install
-endef
+include $(INCLUDE_DIR)/host-build.mk
 
-define Build/Clean
-       rm -rf $(PKG_BUILD_DIR)
-endef
+HOST_CONFIGURE_ARGS += \
+       --enable-static \
+       --disable-shared \
+       --with-gmp=$(STAGING_DIR_HOST)
 
 $(eval $(call HostBuild))