tools/scons: update to 3.0.1
[openwrt/openwrt.git] / tools / quilt / Makefile
index 510d8f6fd5a12b3ff2f58603fe2477f51d600970..d0532b5984ea59116aac426d81bbf3ce2c1b18c5 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 -2010 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,21 +7,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=quilt
-PKG_VERSION:=0.48
+PKG_VERSION:=0.65
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://download.savannah.gnu.org/releases/$(PKG_NAME)
-PKG_MD5SUM:=f77adda60039ffa753f3c584a286f12b
+PKG_SOURCE_URL:=@SAVANNAH/quilt
+PKG_HASH:=f6cbc788e5cbbb381a3c6eab5b9efce67c776a8662a7795c7432fd27aa096819
 
 include $(INCLUDE_DIR)/host-build.mk
 
-GETOPT:=$(shell which getopt)
-
-HOST_CONFIGURE_ARGS += \
-       --with-patch=$(PATCH) \
-       --with-find=$(FIND) \
-       --with-getopt=$(GETOPT)
-
 define Host/Configure
        cd $(HOST_BUILD_DIR) && autoconf
        $(call Host/Configure/Default)
@@ -29,7 +22,7 @@ define Host/Configure
 endef
 
 define Host/Compile
-       $(MAKE) -C $(HOST_BUILD_DIR) SHELL="$(BASH)" all lib/backup-files
+       $(MAKE) -C $(HOST_BUILD_DIR) SHELL="$(BASH)" all
 endef
 
 define Host/Install