sed: upgrade to version 4.2.2
[openwrt/openwrt.git] / tools / sed / Makefile
index 6c0c948c5e92df760e0cc7a32eab731d31ca90c1..27169540b80e689e73a80994f76f347e0d226f70 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,18 +7,29 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sed
-PKG_VERSION:=4.2.1
+PKG_VERSION:=4.2.2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
-PKG_MD5SUM:=7d310fbd76e01a01115075c1fd3f455a
+PKG_MD5SUM:=7ffe1c7cdc3233e1e0c4b502df253974
 PKG_CAT:=bzcat
 export SED:=
 
+HOST_BUILD_PARALLEL:=1
+
 include $(INCLUDE_DIR)/host-build.mk
 
+HOST_CONFIGURE_ARGS += \
+       --disable-acl \
+       --disable-nls \
+
+HOST_CONFIGURE_VARS += \
+       ac_cv_search_setfilecon=no \
+       ac_cv_header_selinux_context_h=no \
+       ac_cv_header_selinux_selinux_h=no \
+
 define Host/Compile
-       $(MAKE) -C $(HOST_BUILD_DIR) SHELL="$(BASH)" LDFLAGS="-static"
+       +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) SHELL="$(BASH)" LDFLAGS="$(HOST_STATIC_LINKING)"
 endef
 
 define Host/Install