sstrip: remove a redundant copy of elf.h
[openwrt/openwrt.git] / tools / sstrip / Makefile
index 8d23e36e8b8b0bbb3c643a039dc319079c62beec..076851f585ea83cfc1ac8dd7838a51bb974cf28c 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,15 +10,15 @@ PKG_NAME:=sstrip
 
 include $(INCLUDE_DIR)/host-build.mk
 
-define Build/Compile
-       $(CC) $(HOST_CFLAGS) -I./include -include endian.h -o $(PKG_BUILD_DIR)/sstrip src/sstrip.c
+define Host/Compile
+       $(HOSTCC) $(HOST_CFLAGS) -I../include -include endian.h $(HOST_STATIC_LINKING) -o $(HOST_BUILD_DIR)/sstrip src/sstrip.c
 endef
 
-define Build/Install
-       $(CP) $(PKG_BUILD_DIR)/sstrip $(STAGING_DIR_HOST)/bin/
+define Host/Install
+       $(CP) $(HOST_BUILD_DIR)/sstrip $(STAGING_DIR_HOST)/bin/
 endef
 
-define Build/Clean
+define Host/Clean
        rm -f $(STAGING_DIR_HOST)/bin/sstrip
 endef