tools/xz: Update to 5.2.4
[openwrt/openwrt.git] / tools / xz / Makefile
index 3dc9da2669f31953cf45cb119285806cc1388309..d6b619db41f5a5a44569c5281a9a86d3b22ef957 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,16 +7,27 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xz
-PKG_VERSION:=5.0.3
+PKG_VERSION:=5.2.4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://tukaani.org/xz
-PKG_MD5SUM:=8d900b742b94fa9e708ca4f5a4b29003
+PKG_SOURCE_URL:=@SF/lzmautils \
+               http://tukaani.org/xz
+PKG_HASH:=3313fd2a95f43d88e44264e6b015e7d03053e681860b0d5d3f9baca79c57b7bf
+
+HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
+HOSTCC := $(HOSTCC_NOCACHE)
+HOSTCXX := $(HOSTCXX_NOCACHE)
+
+HOST_CONFIGURE_ARGS += \
+       --enable-static=yes \
+       --enable-shared=no \
+       --disable-doc
+
 define Host/Install
-       $(MAKE) -C $(HOST_BUILD_DIR) install xzlinks="unxz xzcat"
+       +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) install xzlinks="unxz xzcat"
 endef
 
 $(eval $(call HostBuild))