package/uboot-lantiq: move configuration in submenu
authorNicolas Thill <nico@openwrt.org>
Fri, 16 Apr 2010 11:08:19 +0000 (11:08 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 16 Apr 2010 11:08:19 +0000 (11:08 +0000)
SVN-Revision: 20919

package/uboot-lantiq/Config.in
package/uboot-lantiq/Makefile

index e2c156d884b372177fe4bf52bd1f44692c477ed0..578b088646e5c7116d055c3670280c80b0900770 100644 (file)
@@ -1,7 +1,9 @@
+menu "Configuration"
+       depends on PACKAGE_uboot-lantiq
+
 config UBOOT_TARGET
        string "target"
        default "easy50712_DDR166M"
-       depends on PACKAGE_uboot-lantiq
        help
          The configuration reflects the settings for a dedicated board hardware.
          Select for Danube evaluation board easy50712_DDR166M .
@@ -9,7 +11,6 @@ config UBOOT_TARGET
 
 config UBOOT_RAMBOOT
        bool "Enable RAM boot image"
-       depends on PACKAGE_uboot-lantiq
        help
          Using the UART boot mode of the ROM code this image could be loaded to the RAM.
          While executing the image in the RAM the functionality of the uboot image can be 
@@ -30,6 +31,7 @@ config UBOOT_RAMBOOT_DDR_CONFIG
 
 config UBOOT_A800
        bool "add ARV452 Switch bringup hack"
-       depends on PACKAGE_uboot-lantiq
        help
          Say Y, if you have a arv452 board (wav-281, A800, ..)
+
+endmenu
index 18649087522121a4ceaf489ca0ea5ce85b0b3c22..8b69fe95092c9bbd237d05dc6f959528874b13e3 100644 (file)
@@ -31,6 +31,7 @@ define Package/uboot-lantiq
   DEPENDS:=@TARGET_ifxmips
   TITLE:=U-Boot for Lantiq reference boards
   URL:=http://www.denx.de/wiki/U-Boot
+  MENU:=1
 endef
 
 define Build/Prepare