kernel: bump 4.9 to 4.9.130
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 2 Oct 2018 09:11:53 +0000 (11:11 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 2 Oct 2018 11:44:36 +0000 (13:44 +0200)
Refreshed all patches.

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/ar71xx/patches-4.9/910-unaligned_access_hacks.patch
target/linux/generic/backport-4.9/090-net-generalize-napi_complete_done.patch
target/linux/layerscape/patches-4.9/702-pci-support-layerscape.patch

index 4a734e5688f067362130646b80a96a0aa0fbd8f4..18943d520454e837d10da4672d98414cb66df25a 100644 (file)
@@ -3,12 +3,12 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .123
 LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .123
-LINUX_VERSION-4.9 = .129
 LINUX_VERSION-4.14 = .72
 LINUX_VERSION-4.14 = .72
+LINUX_VERSION-4.9 = .130
 
 LINUX_KERNEL_HASH-3.18.123 = c10de32c9b31fb619b016a00d77afc394db5a4542e258e927f06a5ead86f8c64
 
 LINUX_KERNEL_HASH-3.18.123 = c10de32c9b31fb619b016a00d77afc394db5a4542e258e927f06a5ead86f8c64
-LINUX_KERNEL_HASH-4.9.129 = 6f5510d3fcfec1bf1e2d9c8e2fdcd7628c1886c6bdb29092adc5ccdf75e39318
 LINUX_KERNEL_HASH-4.14.72 = df925906250bbc40fcf0137d7ad0fb8edc528d926832634f1233b7540564557f
 LINUX_KERNEL_HASH-4.14.72 = df925906250bbc40fcf0137d7ad0fb8edc528d926832634f1233b7540564557f
+LINUX_KERNEL_HASH-4.9.130 = 60db3e6a8b00230d5a7c0c8907ef6876702e99c89980bb624f7b649b638b0a7f
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 5c2a435c9f45debf4025d0e080e6f08fcf686560..049ee78d339b194eb8c0cb1e680a030eb448fa16 100644 (file)
  #endif /* _LINUX_TYPES_H */
 --- a/net/ipv4/af_inet.c
 +++ b/net/ipv4/af_inet.c
  #endif /* _LINUX_TYPES_H */
 --- a/net/ipv4/af_inet.c
 +++ b/net/ipv4/af_inet.c
-@@ -1318,8 +1318,8 @@ struct sk_buff **inet_gro_receive(struct
+@@ -1319,8 +1319,8 @@ struct sk_buff **inet_gro_receive(struct
        if (unlikely(ip_fast_csum((u8 *)iph, 5)))
                goto out_unlock;
  
        if (unlikely(ip_fast_csum((u8 *)iph, 5)))
                goto out_unlock;
  
                        goto next_ht;
 --- a/net/ipv6/ip6_offload.c
 +++ b/net/ipv6/ip6_offload.c
                        goto next_ht;
 --- a/net/ipv6/ip6_offload.c
 +++ b/net/ipv6/ip6_offload.c
-@@ -220,7 +220,7 @@ static struct sk_buff **ipv6_gro_receive
+@@ -221,7 +221,7 @@ static struct sk_buff **ipv6_gro_receive
                        continue;
  
                iph2 = (struct ipv6hdr *)(p->data + off);
                        continue;
  
                iph2 = (struct ipv6hdr *)(p->data + off);
index 393c4524e4d28df16a3af2e77fa0d21bd565472f..90a158ec82eb63c2bd9d602b502ed7f2c01051a7 100644 (file)
@@ -1379,7 +1379,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
                 */
 --- a/drivers/net/xen-netfront.c
 +++ b/drivers/net/xen-netfront.c
                 */
 --- a/drivers/net/xen-netfront.c
 +++ b/drivers/net/xen-netfront.c
-@@ -1064,7 +1064,7 @@ err:
+@@ -1070,7 +1070,7 @@ err:
        if (work_done < budget) {
                int more_to_do = 0;
  
        if (work_done < budget) {
                int more_to_do = 0;
  
index 2272a23f46cfe9594dd7167790971e9eb8e18c1f..eb023912058361fbb8c4d795cfbe1dfe3b2c8827 100644 (file)
@@ -2074,7 +2074,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  static void quirk_no_pm_reset(struct pci_dev *dev)
  {
        /*
  static void quirk_no_pm_reset(struct pci_dev *dev)
  {
        /*
-@@ -4679,3 +4686,11 @@ DECLARE_PCI_FIXUP_EARLY(PCI_VENDOR_ID_IN
+@@ -4673,3 +4680,11 @@ DECLARE_PCI_FIXUP_EARLY(PCI_VENDOR_ID_IN
  DECLARE_PCI_FIXUP_EARLY(PCI_VENDOR_ID_INTEL, 0x2031, quirk_no_aersid);
  DECLARE_PCI_FIXUP_EARLY(PCI_VENDOR_ID_INTEL, 0x2032, quirk_no_aersid);
  DECLARE_PCI_FIXUP_EARLY(PCI_VENDOR_ID_INTEL, 0x2033, quirk_no_aersid);
  DECLARE_PCI_FIXUP_EARLY(PCI_VENDOR_ID_INTEL, 0x2031, quirk_no_aersid);
  DECLARE_PCI_FIXUP_EARLY(PCI_VENDOR_ID_INTEL, 0x2032, quirk_no_aersid);
  DECLARE_PCI_FIXUP_EARLY(PCI_VENDOR_ID_INTEL, 0x2033, quirk_no_aersid);