kernel: bump 4.9 to 4.9.111
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 4 Jul 2018 09:54:18 +0000 (11:54 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 4 Jul 2018 12:16:37 +0000 (14:16 +0200)
Refreshed all patches

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/brcm2708/patches-4.9/950-0031-Add-dwc_otg-driver.patch
target/linux/brcm47xx/patches-4.9/830-huawei_e970_support.patch
target/linux/generic/pending-4.9/490-ubi-auto-attach-mtd-device-named-ubi-or-data-on-boot.patch
target/linux/layerscape/patches-4.9/702-pci-support-layerscape.patch

index 641b65258fab6c62a153effe9a88ccaefea5e03c..48c284c6fd276b26fa8eabdfd9862fcc131b0546 100644 (file)
@@ -4,13 +4,13 @@ LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .71
 LINUX_VERSION-4.4 = .121
-LINUX_VERSION-4.9 = .110
 LINUX_VERSION-4.14 = .52
+LINUX_VERSION-4.9 = .111
 
 LINUX_KERNEL_HASH-3.18.71 = 5abc9778ad44ce02ed6c8ab52ece8a21c6d20d21f6ed8a19287b4a38a50c1240
 LINUX_KERNEL_HASH-4.4.121 = 44a88268b5088dc326b30c9b9133ac35a9a200b636b7268d08f32abeae6ca729
-LINUX_KERNEL_HASH-4.9.110 = 379a143a70a79f0eea6c9f6638942b65e6043abdde17ad23264c0abd93c4ea7a
 LINUX_KERNEL_HASH-4.14.52 = a5d226c7b2fd1eb0f01d56e4e2c6a0100784b68df907cc7317f32bde34f88810
+LINUX_KERNEL_HASH-4.9.111 = 5966558959dc580f163766f3fdefd7e57c01b2b45d51202d00b3807c253759dd
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 34e7764668094754b50d7f068c11909fd68a24ed..d19027a2f0f2807fbd3ef0ff1d8f851f564af1a1 100644 (file)
@@ -696,7 +696,7 @@ Signed-off-by: Noralf Trønnes <noralf@tronnes.org>
  }
 --- a/drivers/usb/core/hub.c
 +++ b/drivers/usb/core/hub.c
-@@ -5062,7 +5062,7 @@ static void port_event(struct usb_hub *h
+@@ -5064,7 +5064,7 @@ static void port_event(struct usb_hub *h
        if (portchange & USB_PORT_STAT_C_OVERCURRENT) {
                u16 status = 0, unused;
  
index b6150ed8fd9763ca3534e32173407afa5d6853c9..5d40fe6541616dbe23927fa623326d5a8a9728e3 100644 (file)
@@ -8,7 +8,7 @@
  #include <asm/bootinfo.h>
  #include <asm/idle.h>
  #include <asm/prom.h>
-@@ -225,6 +226,33 @@ static struct fixed_phy_status bcm47xx_f
+@@ -231,6 +232,33 @@ static struct fixed_phy_status bcm47xx_f
        .duplex = DUPLEX_FULL,
  };
  
@@ -42,7 +42,7 @@
  static int __init bcm47xx_register_bus_complete(void)
  {
        switch (bcm47xx_bus_type) {
-@@ -244,6 +272,7 @@ static int __init bcm47xx_register_bus_c
+@@ -250,6 +278,7 @@ static int __init bcm47xx_register_bus_c
        bcm47xx_workarounds();
  
        fixed_phy_add(PHY_POLL, 0, &bcm47xx_fixed_phy_status, -1);
index 1d44cdb9f40b9ac64f46d6b6b1103487c5160a6f..8b37dba034c16c66e015e2cbf6cdb9cff2dda6a4 100644 (file)
@@ -8,7 +8,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
 
 --- a/drivers/mtd/ubi/build.c
 +++ b/drivers/mtd/ubi/build.c
-@@ -1223,6 +1223,49 @@ static struct mtd_info * __init open_mtd
+@@ -1226,6 +1226,49 @@ static struct mtd_info * __init open_mtd
        return mtd;
  }
  
@@ -58,7 +58,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  static int __init ubi_init(void)
  {
        int err, i, k;
-@@ -1306,6 +1349,12 @@ static int __init ubi_init(void)
+@@ -1309,6 +1352,12 @@ static int __init ubi_init(void)
                }
        }
  
index 37eb5410d2efec2f84390bece0b04587331ba988..724c6841f8deed0b61ec8754e173a1eeed520a01 100644 (file)
@@ -2060,7 +2060,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        }
 --- a/drivers/pci/quirks.c
 +++ b/drivers/pci/quirks.c
-@@ -4659,3 +4659,11 @@ DECLARE_PCI_FIXUP_EARLY(PCI_VENDOR_ID_IN
+@@ -4679,3 +4679,11 @@ DECLARE_PCI_FIXUP_EARLY(PCI_VENDOR_ID_IN
  DECLARE_PCI_FIXUP_EARLY(PCI_VENDOR_ID_INTEL, 0x2031, quirk_no_aersid);
  DECLARE_PCI_FIXUP_EARLY(PCI_VENDOR_ID_INTEL, 0x2032, quirk_no_aersid);
  DECLARE_PCI_FIXUP_EARLY(PCI_VENDOR_ID_INTEL, 0x2033, quirk_no_aersid);