package/madwifi: move configuration in submenu
authorNicolas Thill <nico@openwrt.org>
Fri, 16 Apr 2010 10:34:21 +0000 (10:34 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 16 Apr 2010 10:34:21 +0000 (10:34 +0000)
SVN-Revision: 20911

package/madwifi/Config.in
package/madwifi/Makefile

index 7f1e36d04299002f6e4f6a9a1808a0a8cbb660c9..7b72eb854edb28c0b97d693c2d47dc6421241eac 100644 (file)
@@ -1,13 +1,13 @@
-# MadWifi configuration
+menu "Configuration"
+       depends on PACKAGE_kmod-madwifi
 
 config MADWIFI_DEBUG
        bool "Enable compilation of debugging features"
-       depends on DEVEL && PACKAGE_kmod-madwifi
+       depends on DEVEL
        default n
 
 config MADWIFI_COMPRESSION
        bool "Enable Atheros Super A/G Compression"
-       depends on PACKAGE_kmod-madwifi
        depends !TARGET_ar71xx
        default n
        help
@@ -15,7 +15,6 @@ config MADWIFI_COMPRESSION
 
 config MADWIFI_SINGLE_MODULE
        bool "Combine driver and net80211 into a single module"
-       depends on PACKAGE_kmod-madwifi
        default y
        help
          This option combines all driver and stack related code (except for HAL)
@@ -24,7 +23,6 @@ config MADWIFI_SINGLE_MODULE
 
 choice
        prompt "Rate control algorithm selection"
-       depends on PACKAGE_kmod-madwifi
        default MADWIFI_RCA_MINSTREL
        help
          This option controls how MadWifi chooses its bitrate.
@@ -53,3 +51,5 @@ config MADWIFI_RCA_SAMPLERATE
          average transmission time.
 
 endchoice
+
+endmenu
index 4c8415a6bebd80278dc0455e44426ad40c939bed..4f01f008fd7fd3baaaccf2922662ab626ca1d6f7 100644 (file)
@@ -165,6 +165,7 @@ define KernelPackage/madwifi
   DEPENDS:=+wireless-tools @LINUX_2_6 @PCI_SUPPORT @(!(TARGET_avr32||TARGET_cobalt||TARGET_ep93xx||TARGET_etrax||TARGET_octeon||TARGET_pxcab||TARGET_sibyte)||BROKEN)
   FILES:=$(MADWIFI_FILES)
   AUTOLOAD:=$(call AutoLoad,50,$(MADWIFI_AUTOLOAD))
+  MENU:=1
 endef
 
 define KernelPackage/madwifi/description