kernel: bump 4.19 to 4.19.35
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Thu, 18 Apr 2019 13:05:04 +0000 (15:05 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 22 Apr 2019 19:15:17 +0000 (21:15 +0200)
Refreshed all patches.

Fixes:
- CVE-2019-3887

New symbol:
- CONFIG_LDISC_AUTOLOAD

Compile-tested on: cns3xxx, imx6
Runtime-tested on: cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/ath79/patches-4.19/0027-MIPS-ath79-drop-legacy-IRQ-code.patch
target/linux/ath79/patches-4.19/0028-MIPS-ath79-drop-machfiles.patch
target/linux/generic/config-4.19
target/linux/generic/pending-4.19/103-MIPS-perf-ath79-Fix-perfcount-IRQ-assignment.patch
target/linux/generic/pending-4.19/680-NET-skip-GRO-for-foreign-MAC-addresses.patch
target/linux/imx6/patches-4.19/301-apalis-ixora-dts-leds.patch
target/linux/imx6/patches-4.19/302-apalis-ixora-dts-reset-button.patch

index a6c0f6e59cb9daa6b37b1f3941982b1da6e1c2ae..36fc533d17cc5eba6a4bbd52f3f05be5d4f5efea 100644 (file)
@@ -5,12 +5,12 @@ LINUX_RELEASE?=1
 LINUX_VERSION-3.18 = .136
 LINUX_VERSION-4.9 = .169
 LINUX_VERSION-4.14 = .112
-LINUX_VERSION-4.19 = .34
+LINUX_VERSION-4.19 = .35
 
 LINUX_KERNEL_HASH-3.18.136 = 48c8775013d23229462134f911bbb14c7935096fcccfb19ce28ecd5f7154f35c
 LINUX_KERNEL_HASH-4.9.169 = b776636c63a555961cfe9f6f4a315e65ab0ff3376acdb3cf5ad654808ff8d6b0
 LINUX_KERNEL_HASH-4.14.112 = 326101e2cc80a0d7e643074fe9e63f0d6a9c8cf97033f8a07848de373203e472
-LINUX_KERNEL_HASH-4.19.34 = dd795e2a1fddbee5b03c3bb55a1926829cc08df4fdcabce62dda717ba087b8cc
+LINUX_KERNEL_HASH-4.19.35 = 2fa7e560f0e020104c6e09ffb6c2242a8f5c4b5c39e41ed2996fa7b8b42047e0
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 79f003d2ea3df63157deda642af56d3bbabd15c5..6586f084314145968c31768451ef2337a6a8d4d6 100644 (file)
@@ -208,7 +208,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
  
  #include <asm/bootinfo.h>
  #include <asm/idle.h>
-@@ -311,6 +312,11 @@ void __init plat_time_init(void)
+@@ -305,6 +306,11 @@ void __init plat_time_init(void)
        mips_hpt_frequency = cpu_clk_rate / 2;
  }
  
index 0515b206b04d7d1df11bcebd209ad151674e49d0..1901e6e4374a825835550577cd9f574bcf8e7a83 100644 (file)
@@ -944,7 +944,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
  
  #define ATH79_SYS_TYPE_LEN    64
  
-@@ -236,25 +235,21 @@ void __init plat_mem_setup(void)
+@@ -230,25 +229,21 @@ void __init plat_mem_setup(void)
        else if (fw_passed_dtb)
                __dt_setup_arch((void *)KSEG0ADDR(fw_passed_dtb));
  
@@ -979,7 +979,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
  {
        struct device_node *np;
        struct clk *clk;
-@@ -284,66 +279,12 @@ static void __init ath79_of_plat_time_in
+@@ -278,66 +273,12 @@ static void __init ath79_of_plat_time_in
        clk_put(clk);
  }
  
index fe9e25cb3496e86310ba6ea578643a12dafa89f4..3d2dcc010a5b48c4d5cf44eb3fb0664e4a0859eb 100644 (file)
@@ -2447,6 +2447,7 @@ CONFIG_LBDAF=y
 # CONFIG_LCD_S6E63M0 is not set
 # CONFIG_LCD_TDO24M is not set
 # CONFIG_LCD_VGG2432A4 is not set
+CONFIG_LDISC_AUTOLOAD=y
 # CONFIG_LDM_PARTITION is not set
 CONFIG_LD_DEAD_CODE_DATA_ELIMINATION=y
 # CONFIG_LEDS_APU is not set
index 9e97f8af2dbd90baf3236c2fd262eb4c82c94334..6b74c7da1d8b47a1c93e4642a9f7f3865ef3160c 100644 (file)
@@ -66,11 +66,9 @@ Changes since v1:
  drivers/irqchip/irq-ath79-misc.c | 11 +++++++++++
  2 files changed, 11 insertions(+), 6 deletions(-)
 
-diff --git a/arch/mips/ath79/setup.c b/arch/mips/ath79/setup.c
-index 4a70c5d..25a5789 100644
 --- a/arch/mips/ath79/setup.c
 +++ b/arch/mips/ath79/setup.c
-@@ -210,12 +210,6 @@ const char *get_system_type(void)
+@@ -211,12 +211,6 @@ const char *get_system_type(void)
        return ath79_sys_type;
  }
  
@@ -83,8 +81,6 @@ index 4a70c5d..25a5789 100644
  unsigned int get_c0_compare_int(void)
  {
        return CP0_LEGACY_COMPARE_IRQ;
-diff --git a/drivers/irqchip/irq-ath79-misc.c b/drivers/irqchip/irq-ath79-misc.c
-index aa72907..0390603 100644
 --- a/drivers/irqchip/irq-ath79-misc.c
 +++ b/drivers/irqchip/irq-ath79-misc.c
 @@ -22,6 +22,15 @@
@@ -103,7 +99,7 @@ index aa72907..0390603 100644
  
  static void ath79_misc_irq_handler(struct irq_desc *desc)
  {
-@@ -113,6 +122,8 @@ static void __init ath79_misc_intc_domain_init(
+@@ -113,6 +122,8 @@ static void __init ath79_misc_intc_domai
  {
        void __iomem *base = domain->host_data;
  
@@ -112,6 +108,3 @@ index aa72907..0390603 100644
        /* Disable and clear all interrupts */
        __raw_writel(0, base + AR71XX_RESET_REG_MISC_INT_ENABLE);
        __raw_writel(0, base + AR71XX_RESET_REG_MISC_INT_STATUS);
--- 
-1.9.1
-
index 828c9554d4e3b26479a78bdaea0e7286cc51a9b1..a0050cfb442274a6bc1e69aeef5c75b19ad91c1b 100644 (file)
@@ -32,7 +32,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        __u16                   tc_index;       /* traffic control index */
 --- a/net/core/dev.c
 +++ b/net/core/dev.c
-@@ -5452,6 +5452,9 @@ static enum gro_result dev_gro_receive(s
+@@ -5454,6 +5454,9 @@ static enum gro_result dev_gro_receive(s
        int same_flow;
        int grow;
  
@@ -42,7 +42,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (netif_elide_gro(skb->dev))
                goto normal;
  
-@@ -6946,6 +6949,48 @@ static void __netdev_adjacent_dev_unlink
+@@ -6948,6 +6951,48 @@ static void __netdev_adjacent_dev_unlink
                                           &upper_dev->adj_list.lower);
  }
  
@@ -91,7 +91,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  static int __netdev_upper_dev_link(struct net_device *dev,
                                   struct net_device *upper_dev, bool master,
                                   void *upper_priv, void *upper_info,
-@@ -6993,6 +7038,7 @@ static int __netdev_upper_dev_link(struc
+@@ -6995,6 +7040,7 @@ static int __netdev_upper_dev_link(struc
        if (ret)
                return ret;
  
@@ -99,7 +99,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        ret = call_netdevice_notifiers_info(NETDEV_CHANGEUPPER,
                                            &changeupper_info.info);
        ret = notifier_to_errno(ret);
-@@ -7079,6 +7125,7 @@ void netdev_upper_dev_unlink(struct net_
+@@ -7081,6 +7127,7 @@ void netdev_upper_dev_unlink(struct net_
  
        __netdev_adjacent_dev_unlink_neighbour(dev, upper_dev);
  
@@ -107,7 +107,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        call_netdevice_notifiers_info(NETDEV_CHANGEUPPER,
                                      &changeupper_info.info);
  }
-@@ -7702,6 +7749,7 @@ int dev_set_mac_address(struct net_devic
+@@ -7704,6 +7751,7 @@ int dev_set_mac_address(struct net_devic
        if (err)
                return err;
        dev->addr_assign_type = NET_ADDR_SET;
index acec1e8e3d51fba341adb728c3c92b90419403c9..bae9df17347d8509af8f917e59f2b16cc5569a08 100644 (file)
@@ -14,8 +14,8 @@ Signed-off-by: Petr Štetiar <ynezz@true.cz>
 +              led-upgrade = &led_upgrade;
        };
  
-       gpio-keys {
-@@ -123,22 +127,22 @@
+       chosen {
+@@ -127,22 +131,22 @@
                pinctrl-names = "default";
                pinctrl-0 = <&pinctrl_leds_ixora>;
  
@@ -54,8 +54,8 @@ Signed-off-by: Petr Štetiar <ynezz@true.cz>
 +              led-upgrade = &led_upgrade;
        };
  
-       gpio-keys {
-@@ -124,22 +128,22 @@
+       chosen {
+@@ -128,22 +132,22 @@
                pinctrl-names = "default";
                pinctrl-0 = <&pinctrl_leds_ixora>;
  
index ede872fb628e2f83be68a4672c02417366fa24c7..da9de296a2108c1e58ccb3119927c7b8b94bd4aa 100644 (file)
@@ -4,7 +4,7 @@ Signed-off-by: Petr Štetiar <ynezz@true.cz>
 
 --- a/arch/arm/boot/dts/imx6q-apalis-ixora-v1.1.dts
 +++ b/arch/arm/boot/dts/imx6q-apalis-ixora-v1.1.dts
-@@ -70,7 +70,7 @@
+@@ -74,7 +74,7 @@
        gpio-keys {
                compatible = "gpio-keys";
                pinctrl-names = "default";
@@ -13,7 +13,7 @@ Signed-off-by: Petr Štetiar <ynezz@true.cz>
  
                wakeup {
                        label = "Wake-Up";
-@@ -79,6 +79,13 @@
+@@ -83,6 +83,13 @@
                        debounce-interval = <10>;
                        wakeup-source;
                };
@@ -26,8 +26,8 @@ Signed-off-by: Petr Štetiar <ynezz@true.cz>
 +              };
        };
  
-       lcd_display: display@di0 {
-@@ -292,4 +299,10 @@
+       lcd_display: disp0 {
+@@ -296,4 +303,10 @@
                        MX6QDL_PAD_NANDF_D2__GPIO2_IO02 0x1b0b0
                >;
        };
@@ -40,7 +40,7 @@ Signed-off-by: Petr Štetiar <ynezz@true.cz>
  };
 --- a/arch/arm/boot/dts/imx6q-apalis-ixora.dts
 +++ b/arch/arm/boot/dts/imx6q-apalis-ixora.dts
-@@ -69,7 +69,7 @@
+@@ -73,7 +73,7 @@
        gpio-keys {
                compatible = "gpio-keys";
                pinctrl-names = "default";
@@ -49,7 +49,7 @@ Signed-off-by: Petr Štetiar <ynezz@true.cz>
  
                wakeup {
                        label = "Wake-Up";
-@@ -78,6 +78,13 @@
+@@ -82,6 +82,13 @@
                        debounce-interval = <10>;
                        wakeup-source;
                };
@@ -62,8 +62,8 @@ Signed-off-by: Petr Štetiar <ynezz@true.cz>
 +              };
        };
  
-       lcd_display: display@di0 {
-@@ -293,4 +300,10 @@
+       lcd_display: disp0 {
+@@ -297,4 +304,10 @@
                        MX6QDL_PAD_NANDF_D2__GPIO2_IO02 0x1b0b0
                >;
        };