target: add a feature flag for RTC support
authorFelix Fietkau <nbd@openwrt.org>
Thu, 17 May 2012 15:28:09 +0000 (15:28 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 17 May 2012 15:28:09 +0000 (15:28 +0000)
SVN-Revision: 31777

include/target.mk
scripts/metadata.pl
target/Config.in

index 61ae108d547fe99f497996ef09204b7095fa2aba..61cdf0640efa8aa969cd596362b421b05c3bea67 100644 (file)
@@ -183,6 +183,9 @@ ifeq ($(DUMP),1)
     ifneq ($(CONFIG_VGA_CONSOLE)$(CONFIG_FB),)
       FEATURES += display
     endif
     ifneq ($(CONFIG_VGA_CONSOLE)$(CONFIG_FB),)
       FEATURES += display
     endif
+    ifneq ($(CONFIG_RTC_CLASS),)
+      FEATURES += rtc
+    endif
 
     # remove duplicates
     FEATURES:=$(sort $(FEATURES))
 
     # remove duplicates
     FEATURES:=$(sort $(FEATURES))
index 41e6e9cd581917afa7d26ed4a5734ce6099b57f5..d250a719788d95b5f0584fcdeb6875439296e886 100755 (executable)
@@ -161,6 +161,7 @@ sub target_config_features(@) {
                /usb/ and $ret .= "\tselect USB_SUPPORT\n";
                /usbgadget/ and $ret .= "\tselect USB_GADGET_SUPPORT\n";
                /pcmcia/ and $ret .= "\tselect PCMCIA_SUPPORT\n";
                /usb/ and $ret .= "\tselect USB_SUPPORT\n";
                /usbgadget/ and $ret .= "\tselect USB_GADGET_SUPPORT\n";
                /pcmcia/ and $ret .= "\tselect PCMCIA_SUPPORT\n";
+               /rtc/ and $ret .= "\tselect RTC_SUPPORT\n";
                /squashfs/ and $ret .= "\tselect USES_SQUASHFS\n";
                /jffs2/ and $ret .= "\tselect USES_JFFS2\n";
                /ext4/ and $ret .= "\tselect USES_EXT4\n";
                /squashfs/ and $ret .= "\tselect USES_SQUASHFS\n";
                /jffs2/ and $ret .= "\tselect USES_JFFS2\n";
                /ext4/ and $ret .= "\tselect USES_EXT4\n";
index 9e0263e4c244b517e6771ad5713803959e4ad33f..cc42ad1266139d5aa9050a59a95b6a085291fed2 100644 (file)
@@ -33,6 +33,9 @@ config USB_SUPPORT
 config USB_GADGET_SUPPORT
        bool
 
 config USB_GADGET_SUPPORT
        bool
 
+config RTC_SUPPORT
+       bool
+
 config BIG_ENDIAN
        bool
 
 config BIG_ENDIAN
        bool