fix wrong kernel version based nls dependency
authorFelix Fietkau <nbd@openwrt.org>
Fri, 28 Aug 2009 16:26:53 +0000 (16:26 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 28 Aug 2009 16:26:53 +0000 (16:26 +0000)
SVN-Revision: 17436

package/kernel/modules/fs.mk

index 7e3ccf3..bd97a08 100644 (file)
@@ -8,9 +8,7 @@
 FS_MENU:=Filesystems
 
 define KernelPackage/nls/Depends
-  ifneq ($(KERNEL),2.4)
-    DEPENDS:= +kmod-nls-base
-  endif
+  DEPENDS:= +!LINUX_2_4:kmod-nls-base
 endef
 
 define KernelPackage/fs-cifs