mac80211: iwlagn include firmware for 7260 cards
authorFelix Fietkau <nbd@openwrt.org>
Fri, 21 Mar 2014 15:54:37 +0000 (15:54 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 21 Mar 2014 15:54:37 +0000 (15:54 +0000)
This patch enables including the firmware for Intel Dual Band Wireless-N 7260 and Intel Dual Band Wireless-AC 7260 cards in iwlagn.

Signed-off-by: Matthew Reeve <mreeve@tenxnetworks.com>
SVN-Revision: 39988

package/kernel/mac80211/Makefile

index 558618412f64f40d00698bfeb595e94d398eb6e4..724e910fc1974a976be7f145defde1f592332857 100644 (file)
@@ -846,6 +846,13 @@ define KernelPackage/iwlagn/config
                  Download and install firmware for:
                    Intel Centrino Advanced-N 6230, Wireless-N 1030, Wireless-N 130 and Advanced-N 6235
 
+       config IWL7260_FW
+               bool "Intel 7260 Firmware"
+               default y
+               help
+                 Download and install firmware for:
+                   Intel Dual Band Wireless-N 7260 and Intel Dual Band Wireless-AC 7260
+
        config IWL100_FW
                bool "Intel 100 Firmware"
                default y
@@ -1725,6 +1732,9 @@ endif
 ifneq ($(CONFIG_IWL6030_FW),)
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/$(PKG_LINUX_FIRMWARE_SUBDIR)/iwlwifi-6000g2b-6.ucode $(1)/lib/firmware
 endif
+ifneq ($(CONFIG_IWL7260_FW),)
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/$(PKG_LINUX_FIRMWARE_SUBDIR)/iwlwifi-7260-7.ucode $(1)/lib/firmware
+endif
 ifneq ($(CONFIG_IWL100_FW),)
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/$(PKG_LINUX_FIRMWARE_SUBDIR)/iwlwifi-100-5.ucode $(1)/lib/firmware
 endif